It won’t download, help pls

So, even when every cord is connected and should be downloading correctly, the computer is showing a “Failed to verify” message. I have tried switching cords, I have tried downloading it directly to the robot, I have restarted the cortex multiple times. I have restarted my computer, switched the USB port. I don’t know what to do. The message says “Failed to Verify that the serial link is connected to a Robot Controller. Cannot communicate with VEX Cortex SlaveCPU. Master CPU communication is working”

Have you tried a firmware update?

What are you using to program it?

Odd problem that sometimes happens.
Turn the Cortex on. Hold the configure button on it (with a paperclip or something) for about 10 seconds or so. Now, go to https://www.vexrobotics.com/vexedr/resources/firmware and download the VEXnet Firmware Upgrade Utility. Connect your Cortex to the computer and update it. Now, go to RobotC (which is what I think you’re using) and manually update firmware for both the Cortex and the joystick. Next, link the two with an A-A cable. Finally, link with VEXnet keys. The end.