"Jittery" lift motor on Clawbot code

We’re a young middle-school team that uses V5 for competition. We have built the “Crunch” hero robot published by VEX, and are running the pre-installed default code in the V5 brain.

We’ve recently developed a problem, and have no idea what is happening. The lift arm suddenly became semi-frozen and “jittery” on the lift operation. The arm will raise a couple of inches, then stop, with a lot of vibration and jerking, if the lift control is held down. We have found that by repeatedly pressing and releasing the button, the motor will barely activate, lifting the arm by about a sixteenth of an inch every time it’s activated. Our high-school team has build the same robot, and experienced the same problem before we did. They replaced the motor, it worked fine for a bit, then started doing it again. They swapped out the brain, same results - it worked fine for a while, then started doing it again.
With my kids, almost the same story - we swapped out the motor, no improvement. We swapped the brain about 30 minutes ago, and as of this writing, it’s working OK, but…

Can anyone offer any insight as to what is actually going on here, and what might we do to correct the situation? Thank you!!

Could you paste your code? It is hard to debug without seeing it.

Typically caused by sending the motor conflicting values, ie. sending motors several values in the same while loop. Here’s an old discussion about that type of problem (written when everyone was primarily using RobotC and Cortex).

as @9MotorGang suggested, post the code so we can have a look.

4 Likes

But we didn’t write any code. This is the factory-installed clawbot code that comes in the V5 brain, right out of the box.

Was it running continually, and for how long? was It being driven for a long time?

1 Like

Ah, that vital piece of missing information.
Does it work if you leave the robot for a few minutes and let motors cool down ?
Are you running the drive program or the clawbot program in the VEX folder ?

5 Likes

Clawbot program from the VEX folder.

Heat might be an issue. Our high school team, and one of my teams has swapped motors for ones with the low-speed/high torque (red) cartridges. We haven’t really done a “stress test” yet, but in just a bit of regular operations, we have not had the problem re-appear. Still not 100% sure that it wasn’t a motor issue - I’ll put those motors on my standard clawbot (I use for demo and testing purposes) to see what happens.

This seems to have fixed it. No more issues at all after putting in the high torque gear cartridges. The motor cases never felt warm, but clearly the motors were being over-stressed.

1 Like