joy stick problems

we change the batteries in our main joystick and now the robot light is blinking green. we tried to do the troubleshooting it says on the wiki but that just makes the vex net, joystick and game lights to turn red. can anyone help.

Did you pair your controller with the micro controller?

it was paired we just tried to pair it again and it was unable to pair

You could update the firmware on the joystick, cortex, and the keys. This usually solves problems for us.

how do you update firmware on the keys?

now we have two flashing red lights on the microcontroller and joystick

  1. Make sure the batteries are installed the correct way.
  2. Can you control the robot with the joystick and cortex tethered using the A-A cable?
  3. What firmware are you running in the cortex and joystick?
  4. Which VEXnet keys do you have (white or black)? What is the firmware in those (if white). You need V4.25 in the joystick and cortex if you are running V1.46 in the keys.

we were trying to update the to 4.25 on the cortex and joystick but this problem occurred. we are running the newest Version on robotC. we can not control the robot because we need to update firmware to upload code.

To update the firmware in white keys, you need to download an application from the vex website. Then you can plug the keys into your computer and update the firmware. See this website for more information: http://www.vexrobotics.com/wiki/index.php/Software_Downloads

thanks for the help updating the firmware on the vexnet keys sovled our problem