Joystick and Cortex Issues

Howdy. I’m a relatively new robotics teacher and I inherited a ton of stuff. I’m working my way through it, but one issue that keeps occurring is that I’m having issues with updating the firmware on some of my joysticks and cortexes. When I attempt to update, they fail. When I try again, RobotC won’t even recognize the device. This has put about half or a little more of my joysticks out of commission and I can’t figure out what to do.

Things I’ve tried:
Different A-to-A USB cables to make sure it isn’t a cable issue.
Different joysticks on different computers to make sure it isn’t a computer problem.
With and without batteries, with and without the power switch on.
Updating my RobotC software.
Trying to use the config switch on the controller, as I saw mentioned on other posts in the forums.

Windows Device Manager shows the device as Unspecified, ISI MCP2458 HID.


Edit: I tried to just reply, but the website won’t let me. Not sure why. I’m on Windows 7, so I don’t think that should be the issue. Screens of the error and the device manager during error are attached.
Screen 1 Error.PNG
Screen 2 Error.PNG


Sorry to hear you are having issues. What operating system are your PCs running?

If you are running Windows 8 or later, it is likely driver issues during the download when the USB switches from “CDC” to “HID”. Try the Unsigned Windows 8 driver process as described in “276-3245-Windows-8-Driver-Installation.pdf”. It is part of “” and can be found at “”. When you get to the “Installing the Unsigned Driver” section, connect a VEX ARM® Cortex®-based Microcontroller, run ROBOTC “Robot / Download Firmware / Manually Update Firmware / Master CPU Firmware / Standard File…” and then run Robot / Download Firmware / Manually Update Firmware / ROBOTC Firmware / Standard File…”. Move the USB cable to the next USB port on the PC and repeat until all USB ports have this done. The PC may have require several minutes to “Device Setup” install all of the drivers each time the USB cable is moved. Similarly plug a Joystick in to each USB port and run the “Robot / Download Firmware / Manually Update Firmware / VEXnet Joystick Firmware / Standard File…” process. After all of this is done, the PC can be rebooted.

If this does not fix the issue, when the PC shows an error, open the Device manager. Take a screen shot of the Device Manager under Control Panel. Look under Ports (COM & LPT) and under Human Interface Devices. This information can help us decide what to try next.