Joystick keeps losing connection with cortex

Our VEX joystick keeps losing its connection with the cortex. It will work for a few seconds and then it will lose the connection; it will take several seconds before it reconnects and it will do it again. When it is working on the controller the joystick LED is solid green, the robot LEDis a slow flash red, Vexnet LED is blinking fast green, and the game is off; on the cortex the Robot LED is a slow green flash, the Vexnet is a fast green flash, and the game is off. When it loses connection on the joystick we get fast flash red on the robot and solid green joystick. On the cortex, the Vexnet and the game go to a fast flash orange and the robot LED is a slow green flash. We have worked through the flowcharts, updated all of the firmware (joystick, Vexnet keys, and cortex), and the coding is correct. Any ideas? We can’t think of what else to try.

My team had a similar experience last season. It turned out that our battery wasn’t constantly connecting with the cortex, and when we tried to draw power, it disconnected. We remedied this by moving our battery so that the cord didn’t have to stretch as far and/or twist to be plugged in. After adding a backup battery, we never really had the problem again.

Our next step to solidify our connection in the most scientific way possible: tape. We would literally tape the battery connector onto the port, thus preventing it from pulling out.

If this doesn’t work, make sure there’s not anything significant between the two keys, such as a metal box or something. I would assume you’ve already tried this, though.