Joystick led troubles

Ok, so today I was using my joystick with my cortex to test some things and the joystick batteries were getting kind of low so i switched them out. but when i turned the joystick back on, all of the lights were solid red, except the robot led, it was flashing red (single blink). I’ve tried re pairing the cortex and joystick, re-calibrating the controller(but when I hold the 6u and config buttons the robot led just slowly blinks green), and I’ve tried hooking up the joystick to my computer but it didn’t show up at all(not even as a device with a driver error or something). I also tried changing batteries out several times (I’m kinda desparate :P).
Any help with this would be greatly appreciated. Thanks!

Update: I’ve also tried to plug in my cortex to my computer and it’s recognized and works perfectly fine, so I know it’s not the usb cable I’m using. Thanks

Well, somehow it got fixed this morning. I decided to turn it on and just leave it for a bit since it was acting like the batteries were dead. Somehow after a while of just sitting there on the lights finally started to blink correctly and now it works. I don’t know how or why but it works now so yay :slight_smile: