Joystick Paired but no movement

I am a newbie to teaching vex robotics.

I did not realize that the robot was ready to go right out of the box, so I attempted to upload the most recent drivers for the cortex and the joystick. I had no problem doing that task.

After putting in the keys for wireless connection, I turned on the robot then the joystick. All of the lights on the robot and the joystick are flashing as to be expected, but I have no movement with the robot. It is clear that the joystick and cortex are paired as per the lights. It’s like the lights are on but nobody’s home.

My students were able to run their robots right after putting them together. They did not do what I did (thankfully!). So I am confused as to what the issue is. I have following the trouble shooting diagrams to no avail. I have checked my wiring/connections and compared them to my students’ robots and everything looks fine. If anyone has any suggestions I would appreciate the feedback.

Thank you,


Is it possible that your process of installing drivers wiped out the default code on the Cortex? I thought that the default code would remain on the Cortex but perhaps if you toggled something on the installation menu during your driver update, it might wipe out the default code?

Are you using RobotC? I think there is a way to upload a default code directly from RobotC.

I’ve always been told that redoing firmware wipes the code and pairing, so you would have to repair the controller to the cortex. I don’t know if the default code is put on after a firmware install.

To pair the devices, just plug an A-A cable into the cortex and joystick, and after all the lights are green, unplug and plug in the vexnets. Just make sure all unplugging and replugging is done while the cortex and remote are off. You know when the controller and cortex are connected wirelessly when the vexnet light is flashing green (it is solid on a wired connection).

try using an orange USB cord to connect them, and if that still doesn’t work, its a problem with your cortex or controller. if it does work, its a vexnet problem.

Thank you To_Bi_As for your reply!

I have tried that option to no avail.

I will get in touch with Vex and see if they can send me a new cortex.



FullMetalMentor thanks for the feedback I had wondered about that myself. I will contact Vex and ask that very question. I had no problem reinstalling the firmware. According to RobotC everything installed just fine. You would think the software would be intelligent enough to recognize if that was an issue.


TeamBlue, thanks for your reply!

According to the lights I am getting on my controller and the cortex, both are pairing just fine. The orange cable did not make a difference in my case. Seems to me it has to do with the fact that I reloaded the firmware. All of the other robots that I ordered work just fine out of the box.

Thanks everyone! Once I have the solution I will repost for future readers.



The cortex has a default program installed by the factory that allows basic robot control without the need for programming. If you have updated all firmware using ROBOTC, then the assumption is that you will create your own driver or autonomous control programs using that programming environment. ROBOTC includes a simulation of the default program in the “Sample Programs/VEX2/Advanced” folder, it’s called “ROBOTC VEX Cortex Default.c”. Alternatively, if you want to return the cortex back to the factory state you can use the VEXnet firmware upgrade utility available here.

Thanks jpearman! I will give it a try.