Joystick Stuck in Bootloader Mode

Pretty much the title. I was in the middle of updating a very out of date joystick (firmware v 3.25 IIRC), and forced the bootloader as directed by the upgrade utility. At this point the joystick went into bootloader mode (as indicated by the slow blinking green robot light), and was no longer detected by the upgrade utility. I have tried disconnecting and reconnecting the usb cable many times, yet it is still in boot loader mode. I also tried holding down the config button while plugging the joystick in, which as far as I can tell had no affect other than to turn the robot, vexnet, and game lights solid green for the duration of the config button being pressed. i also updated two other joysticks successfully using this same computer and upgrade utility right before this one. Any Ideas as to how i can recover my joystick?

Hi Sazrocks,

Usually you can kick the device out of bootload mode by holding the config button and then reloading the firmware. Just to make sure you are pressing the config button in the correct sequence, here is a recap:

  1. Disconnect Joystick from PC and make sure batteries are off
  2. Press & hold the config button
  3. As holding the button connect the USB cable, from PC to Joystick
  4. At the same time, release the button
  5. At this point you will see a slow blinking robot & fast blinking game LED (both green).

You might have to do it a few times before you get the hang of it, if it does not work please email support@vex.com a screenshot of your Windows Device Manager “Ports” section as the Joystick is connected to the PC. It should look similar to the example attached.
VEX Robotics Comm Port (While Connected).png