Joystick Troubles


My school’s robotics team recently made the purchase of the vex robotics joystick and wifi-keys. We used EasyC to make a Tank 4 Motor code. Using a Male-Male USB cable, we connected the joystick and the cortex, and the code worked really well- we had full control. However, when we replaced the wire with the wifi keys, the robot did not work.

Here is what happened:
-When first plugged in, the wifi keys glowed blue, just for a second.
-The joystick LED was green, and the VexNet LED on both was orange. This continued for about 5-10 seconds, before both VexNet LEDs went red.
-The robot was unresponsive.

We have tried power cycling, switching keys, other codes, and re-doing the wire paring process.

Is there some sort of initialization process for the wifi keys that we are missing? Are they broken?


Hello crazymet,

Thanks for taking the time to contact us.
As you said, you might be missing the proper initialization of your VEXnet Keys.

Do you have the VEXnet Key 1.0 or 2.0?
Please confirm.


Version 2.0


Thanks for the confirmation.
The VEXnet Keys 2.0 require master code version 4.2.x

Do you know which version of master code you are running?
If not, do you have easyC or ROBOTC installed in your PC?


We’re using EasyC V.4


Only the latest version of easyC supports 2.0 communication, please make sure to update your easyC software: Help> Check for Updates.

Once you install the update, please use the “IFI VEXnet Firmware Upgrade” to download 4.2.x master code into your VEX Microcontroller & Joystick.

Let me know your results.

IFI VEXnet Firmware Upgrade.pdf (191 KB)