joystick won't link

Getting a fast amber blink on the the vexnet leds on the joystick and the cortex when power on. After about 10-13 seconds the led on the joystick changes to a slow red blink while the cortex blink continues amber fast.

Everything works fine on tether.
Have gone through the troubleshooting checklist several times.
Batteries are fully charged (checked with “get vex system info” from download window in Easy C V4)
Have done firmware upgrade to 4.2
have tried numerous times to re link the joystick to the controller.
have tried several different sets of known good vexnet keys v. 1.0
have tried linking another known good joystick and the problem persists.

I am thinking the cortex itself is pooched???

thanks for any insight.

Hello blueboy,

If the Cortex is able to accept easyC code and its able to recognize the Joystick in tether mode, most likely its not broken.

Have you downloaded the 4.x.x firmware into both the Cortex & Joystick?
If so, can you attach a screenshot of your “IFI VEXnet Firmware Upgrade”



Thanks Eli for the quick reply

I think I have discovered the issue. I brought the unit into my office to turn it on and get the screenshot you requested and the joystick and cortex linked perfectly.
This made me think that something in the main classroom was interfering. A bit more testing here and there and that seems to be the issue. Linking works fine outside or in my office but not in the classroom or the halls. I am thinking the school wifi is somehow interfering.
Is there a solution to that? Would one of the new 2.0 keys solve that interference?

thanks, Doug.