Joysticks won't send any signal to the robot brain.

I just got my Vex kit today and assembled the robot to the motor stage. Fully charged both the controller and the brain battery. Controller by USB cable and the brain battery on the charger. Tried to test the bot and I got no joystick activity transmitted to the brain, either by tether or radio. I get activity on the buttons, but no movement on the motors at all, even after the update. The version downloaded to the brain was 1.05, motors and controller were fully updated. After updating, I got error code 1 on the display.

I restored the robot brain back to ver. 1.02 and when I tethered the controller back to the brain to configure it I got the Fatal Error Code 17.

I ran the updater again and tried to configure the controller and it still will not run the motors at all.


Please attach a screenshot of your “Brain” tab under the run menu.
In order to get to your brain tab follow this steps:

  1. Tether Joystick to brain (

  2. Select “Driver Control”

  3. Select “Run”

  4. Make sure clock on the brain is counting up
    If not, repeat steps 1-4

  5. Push the brain down button twice (V)

  6. “Brain” tab will show all detected motors in this screen


Ok, I will try those steps when I get the chance. I am going to be busy this evening but will try to find the time after I get home. When I ran the updater it showed that all four motors were connected to the brain, as well as the controller. Thanks for the quick reply. BTW, I cannot see the picture you posted.

Ok, I am going to try to download a shot of the brain with all four motors attached to ports 1, 6, 10 and 11. The two motors attached to 10 and 11 worked fine on the buttons, the ones attached to the ports 1 and 6 are unresponsive to joystick commands. When I attached the motors from 1 and 6 to ports 10 and 11 they worked as well. All motors gave me + or - 122 rpm’s on ports 10 and 11.




I recommend you to calibrate your IQ Controller, as this has fixed such issue before.
For the Calibration procedure, all you have to do is the following:

  1. Tether Controller to Brain (

  2. Press (X) on Brain

  3. Select “Calibrate Controller”

  4. Rotate thumb-sticks 360°

  5. Wait 30 seconds, and make sure the Brain LCD updates to the following values: 0,127,255

  6. Press (✓) to save

Let me know your results.


Thanks, Eli. I will attempt this when I get home this evening. Does it matter which direction I rotate the joystick?


It does not matter.


After several attempts to calibrate the controller I was successful. When I was looking at the manual, this procedure was not there. Shouldn’t this step be in there? Oh, as an aside, my cats were amused and very curious about this new moving thing in their world and after I put the 'bot up our oldest cat laid on top of the container as if to claim it as her own… LoL. :smiley: