LRT Controller Woes

Hello, we’re competing in a live remote tournament tomorrow and we’re trying to get the practice software to work, but the website will not connect to the controller. We have the Experimental Web Platform Features enabled and the brain software is up to date. We’ve tried different USB ports, different laptops, different cables, but nothing works. The controller does show up as an option on the website, and after we click connect it says “paired”, but the indicator light stays red, and won’t turn green.

Any ideas?

1 Like

Did you start a program? You need to start a program and be paired to the brain before RobotEvents will let you in.

1 Like

Yeah, we tried that. Just tried it again, it still isn’t working. Thanks for the response, though. And happy birthday!


… and happy cake day to you today!

I had this happen to one of the teams in their practice match yesterday, I got it to work by:

  • Clearing cookies out of Chrome
  • Restarting Chrome
  • Logging back into the environment

In the debug session with the RECF support, the LRT system is very sensitive to clock time deltas. They recommend doing a time synchronization (Look at the Date and Time options in the control panel). Mine were fine, but you might also want to check that.

You also might want to look at the USB cables you are using (swap for another one). You may have a signal issue (even though windows/chrome sees the controller on the serial port.


Thanks for the help! I’m on this team, and seeing as we competed yesterday, we did figure out how to connect our controller.

  1. We were using a laptop running linux, and while that shouldn’t make a difference, switching to a windows laptop did do the trick.

  2. We had VexCode open at the same time as the lrt software. Since both were trying to communicate with the remote, the LRT had a hard time.

I will say, the actual competition was much much smoother than the practice site, so if you have similar issues and are reading this, don’t be discouraged.