Magic fix

I was having the problem of whenever I connected to the second motor port the motor would just spin and nothing would control it (either the remote or programming). I have just worked around it for a while now and decided to open up the microcontroller. I cleaned it out with some compressed air (it was really quite dirty) and put it all back together. It still didn’t work and so I stopped where I was.

I tried it again today and it worked now! No idea what it was! Pretty weird though, ohhhh ehhhh ohhhh. :slight_smile:

does this happen with all of your motors? if not, than it is probably just the motor. but if it does happen to all of them, there might be some sort of short in the controller, and i dont think there is anything that can fix it. the only other guess i would have is that it is not properly trimmed, but you said it doesn’t work with both remote and programming, so that might rule that idea out. i too have some major issues with my controller, but i dont know if there is anything to be done about it.

Sometimes all it takes is pulling the thing apart and putting it back together to fix a problem. That worked with my laptop, although my right shift key now sends in random letters and stuff when you press it :confused:

(I kinda spilled some sauder on that part of the system board)

I don’t think you read my post closely. I fixed the problem.

I had a problem a little similar. My microcontroller wouldn’t do anything and got hot. I unplugged all of the unimportant wires from the controller, and it just magically worked again! Maybe you have a motor or sensor that’s shorting it.