Major Gyro bug!!! Please Help

Hello i am a member on team 2552 the PiThons. we have encountered an interesting issue… We have 6 Gyro sensors and none of them work! We have done multiple things such as swapping brains, swapping wires, putting one gyro on a brain, and we have tested it on 4 different brains and all of them had the same result… 4 of them always think they are colour sensors and the other 2 think that they are nothing. we really hope that you can help. Thx. Also here is a link to a video showing the exact problem (We are running all the latest software). https://www.youtube.com/watch?v=rpGRrrToXj4

Thx for any help - The PiThons

Happy Pi Day!

Put a single gyro on port 1. Run the firmware update. Repeat for each gyro separately, restarting the brain each time.

This fixes most gyros. For the rest call Vex support and ask for a replacement.

Search the forum for more details, this has been discussed a few times before.

Thank you and happy Pi Day as well. We have already tried this after seeing previous forum discussion and it has not worked so we have ordered more. But for anyone else Is there a way to fix this issue.

Wow all 6, that’s bad. Only a couple of ours still didn’t work after running the firmware update on them from port 1, with nothing else connected to the brain.

We can believe that. Those gyros are the most problematic. We had several go bad.

Hi Zach PiThons,

We’re sorry that you have encountered this issue. Please contact VEX Technical Support at support@vex.com or by calling +1-903-453-0802 so we can help to resolve this situation and make everything right.

Regards,

  • Art