Microcontroller Malfunction?

I just got my kit after Christmas. But whenever I load a program the microcontroller starts to send pulses to all the motors about 2x a second. The Microcontroller’s displays show the battery led flashing from green to red along with the eye. The program status led flashes slower that the eye and battery led. On the IFI/intelitek Loader screen it reads :

VEX-Master v7, User v20.01

It repeats this on every pulse.

However when I disconnect any motor the Microcontroller starts to work perfectly, even if I reconnect the motor. But if I start the controller with a motor already disconnected, everything pulses once or twice then returns to the program. I reloaded the master code and then loaded my program but that didn’t work. I tried some other programs I made and got the same result.

Is my microcontroller broken? I never dropped it or damaged it. Do I need to send it back to be replaced? Please advise.

It sounds to me like your battery is too low.

The VEX Microcontroller tends to “twitch” all the servos/motors when it powers up, which causes an instantaneous power draw at the same time that all the power capacitors in the controller are trying to fill, etc. Basically, the power-up demand causes a marginal battery to dip its voltage just enough to cause the microcontroller to detect a brown-out and reset. This just starts the cycle all over again.

Hope that’s it.

  • Dean

Hey thanks I’ll get back to you when I get some results.