Microcontroller wont talk to laptop

When I try to download a program to the controller I am getting an error over and over (see attachment). I have dled the latest version of robotc and the usb - serial drivers but its still not happy.

The battery is not low,
I dont see how the cable could be wrong,
and I dont know how to change the port?

Does anyone know whats wrong?

We have updated ROBOTC to address this issue. Please do the following:


Uninstall ROBOTC 1.70
Install ROBOTC 1.97
Download Master Firmware
Download User Firmware
Try a Sample Program

Several questions to help pinpoint the problem.

*]Are you using orange cable directly plugged into the VEX or are you using the new Wi-Fi VEXNET?
*]Has it worked in the past for you or is this the first time you’re trying to use ROBOTC?
*]What version of ROBOTC are you using? You can get the version number from the “About” screen.
*]Did you ever download appropriate firmware to the user processor? To the master processor?
*]Occassionally after doing the initial firmware download to the VEX, you have to power cycle the VEX before it can be recognized by the PC.
[/LIST]Assuming you are using a direct connection to the PC via orange cable, I’d try the following:[LIST=1]
*]Sometimes Windows “locks up” the serial port that is used to connect to the orange cable. This can sometimes be corrected by:[LIST=1]
*]Exiting and re-starting the ROBOTC program on Windows.
*]Moving the orange cable to a different USB port.
*]Restarting Windows will always recover this situation.
*]Use the “Download Master CPU firmware” command found on the “Robot” menu.
*]Use the “Download VEX firmware” command found on the “Robot” menu to reload the flash memory contents of the VEX User or Slave CPU.
*]Now try “Compile and Download Program” command to send the incremental instructions for your specific program to the VEX.
[/LIST]ROBOTC is an interpretative system. This means that you must initially (and once only) download a large firmware program containing an operating system and interpreter to the VEX. An individual user program is then a small incremental download to this; and when you change your user progrm you then only download the changed data that replaces the previous incremental download.

If your initial large firmware download is corrupted then the subsequent incremental download will not work. Corruption is rare because the data is stored in read only flash memory – the same type of memory used in a PC’s “USB Flash Drive”. But corruption of the main firmware can occur if anattempt (i.e. even incremental downloading of user program) is made with a low battery condition.

For faster response you can email me directly at [EMAIL=“[email protected]”][email protected].

Numbers 4 and 5 were my issues. Thank you.