Mod Kit Videos

My team(2049) has been working on Mod Kit “how to” video series to help teams out…you can find the videos on the following links, I uploaded them on teachertube.com because most schools block youtube.com More to come…

Password: 2049

http://www.teachertube.com/viewVideo.php?video_id=307372

http://www.teachertube.com/viewVideo.php?video_id=310637

http://www.teachertube.com/viewVideo.php?video_id=311965

http://www.teachertube.com/viewVideo.php?video_id=309558

Enjoy,

Bart

I don’t find videos for VEX IQ. There are videos for Arduino, Raspberry PI and NXT but not VEX IQ

Never mind. I can get to the videos now.

http://www.youtube.com/watch?v=ELo481zsbTI&list=PLvvcc7S26YEgp60fNJwh64aj9ywiZ79Ta is a pretty good video on the sensors

Thanks Bart, very helpful confirming I am on the right lines with use of Modkit - just having some trouble getting the ports to work on the controller. Hopefully the Vex guys will help sort this out as it’s a new kit that arrived yesterday.

Andy

Thanks for posting these! My team has been getting 12C error codes. We had VEX replace our brains and radios and still got them. Someone suggested changing from RobotC to Modkit and we havent had a problem yet (knock on wood). It’s nice to see some help put out there so thank you!

I hope to have more up this week…

Thanks for posting the videos. My students and I have been playing with Modkit trying to figure it out. We did the first video but the motor doesn’t spin.Tried changing to different motors in other ports but that didn’t work either. Motors work fine in driver control. Firmware is all updated. Program shows up in the appropriate slot in the brain but when the check is clicked, nothing happens. Any suggestions?

Beecher, Check the following items

  • Are you scrolling down to the program you created, not driver control and click on the check mark on the brain?
    -Make sure each block is locked in place under brain and motor in block view.
  • Make sure the motor port your using in modkit matches the motor port your using on the brain.
    -Double check the smart cable is “clicked” in at the brain and motor.
    -If turning the motor by degrees make sure you don’t have it set to small like 1 degree, my students often want 1 revolution and they forget to select it in the dropdown

I have to say that driver control and autonomous were pretty straightforward. My A team is going to use the bumper and gyro sensor. I am finding these to be a bit more challenging. Guess it gives me something to figure out during the break.

We are working on videos for the other sensors over the break, check back soon…

Great, looking forward to it! If I figure them out, I’ll try to post too. Getting, for instance, the bumper to work within a line of functions and with multiple wheel motors is my only hangup (go forward, turn right, back up until the sensor is bumped then do something etc. etc.) . Doing these in regular VEX with RobotC is easy but since RobotC isnt working for us in IQ right now (they are looking into it), it would be nice to figure it out. Have a good break everyone!

I am having a frustrating time with modkit. I followed your video exactly. When I download the program, it tells me error programming. It doesn’t tell me anything else, so I don’t know where the error exists. Anyone else having problems?

jgillespie,

I have had this happen a few times and this is what I have found that causes/fixes the problem…

  1. Are you on a schools computer? Do your account settings let the driver install when the USB is plugged in? (use the same USB port every time)
  2. Are you running modkit link?
  3. If you open modkit and continue without the brain plugged in do the programming then later plug in the brain to download you will get an error. (you will need to close the explorer window and restart)
  4. I have had problems with my schools laptops that run XP but no problems with windows 7 computers
  5. Motors in robot view ports are not all selected or sometimes the plugs on the brain on robot view disappear and you need to re-assign the ports to the motors in robot view you make this re-appear.

Bart

modkit no brain.jpg

Bart,

  1. I am on my personal laptop, which is running windows 7, and I use chrome.
  2. Yes
  3. The brain is plugged in, and modkit sees it when it loads up
  4. Everything seems fine in the program

I really wish it actually said more than “error programming”

I have tried restarting my browser and computer multiple times too.

Thanks,
James

Can you download any projects? Try creating a simple program that when started it prints hello on the screen and see if you can download it. (see attached picture)

  1. Project->New Project
  2. Block view
  3. When Start.-> print hello

Check to see if you can down load that, when you run this it should print hello on the screen, if it will not download I have no idea…

I understand your pain that it does not tell you what the error is, it just says error…

Bart

Start_hello.jpg

Bart,

Didn’t work. I even tried it all again on a different computer. Sign this is so frustrating. Time to try a different brain, and see if I have any luck with it. I can’t download anything =

Thanks,
James Gillespie

James,
I’m sorry to hear you’re frustrated. Did the 2nd brain help? Can you reach out to our tech support guys and see if they can talk you through it? support@vex.com or 903.453.0802.
We want to get you going!

-John

Just wondered if anyone has had luck with the sensors yet? I have been trying for a few weeks but to no avail. I did make a video on variables that may be of help (hopefully). I made other videos for my kids but they are similar to what has already been posted here.

I have figured out the LED touch sensor and the range finder, I’m working on eiditing the video now I hope to have it posted to teachertube later this week…

Bart