MODE button on Vex transmitter stuck in pressed position

The MODE button our Vex transmitter is stuck in the pressed position. The controller is the large version, but relatively new - about 3 months. Any suggestions on how to fix the issue?

Have you tried sticking a small screwdriver in it to get it un-stuck? If that is to no avail, you may have to take apart the transmitter, and lift the top panel off (if possible) to fix the button.


I haven’t tried a small screwdriver…just my fingers trying to wiggle it around to get it unstick. I’ll try that tomorrow. In case it doesn’t work, anyone know which screws to take out in order to lift off the top of the transmitter and get access to the MODE button? Thanks y’all.

I had this same problem and had to disassemble the controller and scrape the button’s location so that it would not be trapped anymore. I could not let him go with a small screwdriver

I took out the screws from the back of the transmitter and inside the battery area. This lifted the back of the transmitter, but the MODE button was still hidden from view by the parts inside. Does someone know how to get access to that MODE button more easily?