Modkit doesn't work without Modkit link

I have a computer that I’ve used to run Modkit (web version) but not for programming robots and now every 5-10 seconds it will put up a message that says “Opps, can’t find Modkit Link…” making the software unusable on that computer.


Aloha Steve,
I’ve noticed that same problem on the “Modkit for Purchase” software that was provided to coaches just recently. My Modkit screen was stuck on “Waiting for Link” for awahile. So I shut the Modkit program down. I clicked on the Modkit Link icon. I made sure the icon appeared in the lower right hand corner of my PC. Then I started Modkit and it worked. I haven’t thoroughly tested out this method but it worked for me at least a couple of times. I hope this helps.


Not exactly. I saw the same thing with our Desktop Modkit.

I assume when they started making the desktop version available, they also made changes to the web version, which caused this problem. The web version no longer seems to be useable (message pops up every few seconds), unless you have Modkit Link installed.


Oh no. Hopefully the Modkit tech support can offer some assistance.

It’s not really a tech support issue. It’s a new bug that was just added.

Hi Steve,

Thanks for bringing this to our attention. The issue has been resolved. If simply reloading does not fix it for you, you may have to delete your browser’s cache to get the latest version.

Let us know if you have any further issues.


That browser window is long gone… Reopened on the same computer, works fine, now.