Modkit: Download Button Doesn't Work

I have been trying to download a Modkit program onto a robot brain all morning.
Whenever the download button is pressed, it appears to do nothing.
Anyone else experiencing this problem?

I tried downloading the program from two different computers, tried two different brains, made sure everything was updated, reinstalled all the software… Pretty much everything I could think of.
Any suggestions would be greatly appreciated.

Mike,

We’re sorry that you are having this problem. To help correct this situation, we have a few questions.

Did you install Modkit Link onto your computer prior to opening the Modkit web page in your browser? Modkit Link acts like a bridge between your web browser and your VEX IQ Robot Brain, and allows programs to be downloaded. If you have installed Modkit Link and it is running, please check for the yellow Modkit “M” icon in your computer’s system tray (this will be near the clock in the bottom right on Windows and the top right on Mac OSX). If you do not see this icon here, please run Modkit Link; if it does not show up after double clicking on the shortcut icon then please check to see if your anti-virus software is blocking this program.

Once Modkit Link is running and you have connected your Robot Brain to your computer, you will need to select a download slot before you can click on the Download icon:


Download | Play | Stop buttons with Select a Slot drop down menu

You must choose 1, 2, 3, or 4 before clicking the Download icon - these numbers correspond to the numbered program slots available on your Robot Brain. You must choose a program slot every time Modkit is started - the reason for this is to prevent accidentally downloading and overwriting an existing user program on your Robot Brain. After you assigned a program slot, click on the Download icon (arrow pointing down) to download the current program to your Robot Brain. Clicking Play will run the program, and clicking Stop will stop the program.

For your reference, if you go to the Project ▼ drop down menu and and select Download from there, it will download your program from the cloud to your personal computer as a .mkc file. This does not download the program to the Robot Brain.

Regards,

  • Art

Thank you for your response, Art.
I did install the Modkit Link prior to trying to download. I also tried reinstalling it a couple of times.
The Modkit Link icon appears in the lower left-hand corner of my computer indicating that it is running.
I have successfully downloaded many programs in the past, so I know there is no firewall or antivirus issue.
I also tried all of this on a different computer (which worked for downloading programs in the past) and had the same results.
I successfully connected the hardware and this was confirmed by the pop-up message on the computer screen.
I selected the slot, and it did not work. I then tried every other slot. I had the same result every time - it is as though the download button serves no function whatsoever.

Given that the procedure outlined above did not work (on different computers, with different brains, after reinstalling, etc.), what are the next steps in the troubleshooting process?

Hi Mike,

We are sorry you are experiencing difficulties.

Sorry if this is repetitive but please follow these steps to ensure you are using these exact versions (if you are using the pre-release desktop version please let us know as you may need to get an update)

  1. Ensure that your firmware is up to date (v1.10) by following the instructions at: http://www.vexrobotics.com/vexiq/software/firmware/
  2. Close the firmware update utilty if you will be programming the VEX IQ on the same computer.
  3. Shut down Modkit Link by clicking the “M” icon (in menu bar on Mac or task bar on Windows - may need to click arrow to find the icon in “additional items”) and choosing “Quit”
  4. Launch Modkit Link and confirm that it is running by locating “M” icon
  5. Turn on VEX IQ brain and plug it to the computer through USB
  6. Load the editor at http://modkit.com/vex/editor (if it is already open please refresh the page) and click “Continue”
  7. The VEX IQ Brain should be detected. Select it and click “Continue” again. If not detected click “Refresh” and try again
  8. Select slot 1
  9. Press the download (down arrow next to play button) to attempt to program a blank program. You should see “Programming Device” Flash in orange and then change to “Programming OK” in green

Was this successful?

If not please describe what happened if anything.

Thanks,
Modkit