Modkit for Ipad fails to compile

I am working on evaluating the Modkit iPad app along with blue smart radios for use in an elementary school IQ program. I am having difficulty getting Modkit to compile if I use ‘Controller Actions’.

I can create a project on the iPad including a brain and controller, create motors, drivetrains, etc. and program them using blocks. This all works correctly, and I can download and run the program on the brain. However, when I try to map controller actions (using the controller icon for the drivetrain object in the robot editor), Modkit shows a red bar and fails to compile when I try to download. I have tried recreating the project, but the project always fails to compile when a controller action is present. If I remove the controller action, the project compiles correctly again.

Has anyone seen this issue before, and do you know how to resolve it? I tried contacting Modkit support but they did not respond.

Yep, just tested it and I have to agree. I can’t find a work around for this but it must have worked at some point.

I contacted Modkit about the issue a week before posting this (almost a month ago now) and haven’t heard back. It’s very unfortunate that Modkit doesn’t support their product (or test it, apparently). I’ll post post an update if I hear from Modkit.

Autonomous only programming works correctly, so that’s a start.

Wierd thing is, I’m sure PLTW were using the iPad app widely but perhaps just not driver control.

PLTW initially used ‘Remote Link’, where the iPad would use Modkit Link on a full computer with USB connection to the brain. I’m not sure what all has changed in the Modkit app since then. I haven’t tried using Remote Link, maybe it works correctly.

Hello apalrd,
Sorry for the extended delay. We have been deep in development with a new version of the software and a new support model. We will not be handling support with the new software and because of some inevitable delays we’ve been caught in a support no-man’s land where we are no longer set up to support the old software and the new software and support model are just going into private beta.

With that said, the issue you have brought up is a known issue. The problem is we did that version for PLTW and it was only available through them for over a year and as you noted it initially used a different compiler solution. It also didn’t use that in the curriculum and the whole drivetrain was disabled because the focus was on programming all of that from scratch.

Then we worked out a deal to release it publicly for free while we worked on the new software and enabled a bunch of things not enabled in the private PLTW version. Somehow the bug slipped in as the iPad version uses a different compiler architecture and we haven’t been actively supporting it so here we are.

With all that said, I’d like to fix the issue if it’s still important to you (as you noted there are various other ways to get that functionality including the Remote Link to the desktop compiler). I’ve reached out via email so If you’re interested in testing I can probably get you a version with a fix through Test Flight in the next week or so. The dev team has been focused on getting some amazing new tools out the door but our intention is not to leave existing or previous users hanging as we make the transition to a new model. Let me know if you’re interested in testing a potential fix.

It would be great to have a working version until the new software is out. We have a number of users with Smart Radios who can’t use iPads for competitions.

We have the same issue here, and since students only have ipads this is really a show stopper. Any chance the new test code will be available soon? We’d love to try it.

I’ve been in email contact with Ed (Modkit) since his post on the forum. His latest email to me said the fix was more difficult than he thought, but he hoped to have a fix ready by Friday (11/10/2017). Considering he’s had 3 months since I emailed him (end of August), I wouldn’t hope for a fix in the next month or two.

Thanks apalrd - If you would be so kind as to post here when you hear anything further we’d really appreciate it!

Ed got me a beta this weekend, and it seems to work correctly. I’m not sure when he will roll out an update in the app store.

We would love to get our hands on the current version!

BUMP for this need it asap

Also this might help. Just fired up my old MacBook (not sure what OS but it’s old) plugged in the robot and boom it works. So that being said it’s got to be on modkit side not ours.

Definitely works with browser program, but we need it for the ipad app - all students here have ipads, not desktops. Love the bluetooth hookup, but really problematic not to be able to program controller.

Has there been any progress on this problem? August 2019 and still cant use the controller with the iPad Modkit app. Our school elementary team is trying to get ready for the Squared Away Challenge and this is a real problem.

Consider switching to VEXcode IQ blocks at this stage.

1 Like