Modkit for VEX IQ "Download" Button stopped working.

This just happened to our VEX IQ Brain with ModKit programming environment. The following is what we have attempted:

  • Before this problem happens, everything works fine. And in a sudden, when you press the “Download” button, nothing happens. No “Programming…” or “Programming OK” message anymore.
  • We updated the VEX IQ brain, motors, controller and sensors to the latest firmware version. Tried again, no response from the download button.
  • We disconnected/reconnected the battery. Tried again, no response from the download button.
  • Restarted the ModLink program couple of times. Tried couple of times, Modkit reports VEX IQ disconnected/connected. no response from the download button.
  • Tried on a different Mac and got the same result.
  • Tried the “Play” and “Stop” buttons to the right of the “Download” button, display says “error playing” and “error stopping” with the correct slot # selected.

We are using the Modkit for VEX - Editor from here:
We are running Modkit Editor/ModKit Link on the Mac with OS X El Capitan.

We are still trying the environment, so we haven’t purchased the license yet.

For now, we don’t know the reason why this is happening and there is no solution to it yet. Tried to figure out how to factory reset the VEX IQ brain but there is no luck either. We are not sure if it’s Modkit problem or the VEX IQ Brain stopped working.

​@ModKit and @VEX_IQ_Support , please suggest. This paused out project.

Thanks a lot!

We tried to search for the forum for similar problem, but the solutions we found & tried didn’t help.

We had the same type of problem. After programming and disconnecting the robot about 10-15 times, Modkit would stop communicating with it. The solution was to reboot the PC.


Thanks Steve for the comment. I thought about the same thing and rebooted the Mac couple of times. As I stated in the original post, with ModKit Link running, the ModKit Editor actually is reporting “VEX connected”. It’s just the when trying to download the download button has no response whatsoever.

I started to wonder if it’s because of some security settings of the browser. Switched between Safari and Chrome couple of times and no luck there.

As I said, we had the problem. (on a PC)

My suggestion would be to shut everything down (computer and robot), unplug the robot, and start it back up.

One other thought is to create a new program and try to download that, just to make sure it’s not a bug in the program causing an issue…


We have had this problem, actually more than a few times.

Try this…make sure you type in the modkit for vex in the internet search and not use a bookmark or saved page icon. Then click on the try for free. This has actually worked for us. Another option we have used, before we discovered the saved page issue was to use a different PC to download. I hope this helps. Good Luck!

At last, good news. I took the VEX IQ Brain to my work place and tested on a Windows PC, with the same cable, same brain and everything works fine. Notice that the ModKit Link versions are the same for Mac and PC: 2015.04.02.0

Here is my guess: I think ModKit recently updated their VEX IQ Web Editor on the server side but it has some compatibility issue with Mac users.

Special thanks to Ed at ModKit for helping me debugging this problem. And thanks to @Drift as well.

While the problem on Mac remains, I plan to let the players do programming in a Windows VM (Tested and working).