ModKit Link won't start after installing 2014-05-28 update

I’m fairly new to ModKit and Vex. We have a Vex IQ kit with which we’ve built remote-control projects, but I had never tried to program the brain before. Today I installed the recent VexIQ 1.19 firmware update onto my hardware and then started up Modkit Link (which I’d installed earlier) and went to the “ModKit for Vex” site to try to create a simple program. The Modkit interface told me that my version of Modkit Link was out of date, because I hadn’t yet installed the 2014_05_28 version. So, I quit Modkit Link, downloaded the update and installed it. When I tried to start the new version, nothing happened. I found a message on the Console that read

7/25/14 3:30:35.536 PM sandboxd[120]: ([474]) QuickLookUIHelpe(474) deny file-issue-extension /Applications/Modkit Link.app

… but no other hints about what might have happened. I’m running MacOSX 10.9.4 on a 5-year old Macbook Pro, in case that’s relevant. I tried restarting the machine, but that didn’t help. Any suggestions?

Hi TomP,

Wo’re sorry that you are having this problem. To help resolve this problem, please open your System Preferences and then go to the Security & Privacy pane. Then (if necessary) click on the General tab to display the security settings for OSX. Is there a message displayed here that says Modkit Link has been blocked?

There is a new security feature in Max OSX 10.9 that blocks Apps downloaded from sources other than the App Store. To allow specific blocked apps, click the Open Anyway button next to the error message about Modkit Link in the Security & Privacy pane. Modkit Link should now open - if you do not see the yellow M icon in the top menubar, please double click Modkit Link from your Applications folder to launch.

Regards,

  • Art

Hi Art,

The procedure you described was necessary when I first installed the new version of Modkit Link.app. The OS puts up a warning dialog explaining that the app can’t be launched without explicit approval because it’s from an untrusted source. But, the app didn’t launch after I approved it, and it still doesn’t launch now, when I double-click the app icon in the /Applications directory. The warning I saw initially doesn’t show up anymore, so I think the problem I’m facing is something different.

There was one other Modkit-related message on the Console. I didn’t mention it earlier because I saw similar warnings for a number of other programs that were (as far as I know) still working correctly. The message was

7/28/14 11:36:35.518 AM gkbisd[163]: Unable to collect cdhash for /Applications/Modkit Link.app (error code 100024)

There’s some discussion about warnings like this on the Apple Support forums, but I haven’t found any statement yet explaining exactly what it means and whether it represents something that needs to be fixed or not.

Tom

TomP,

We’re sorry that you are encountering this problem - we have not seen this specific problem before.

To help resolve this problem as soon as possible we have forwarded this problem to Modkit for further analysis to identify a solution.

Regards,

  • Art

TomP,

Thanks for bringing this to our attention. We’re following up with your original support email but we just wanted to let others know we will begin signing Modkit Link and will work with you to ensure this is enough to fix these specific issues. If anyone else has issues with this they can always post here or email vex at modkit dot com.

Thanks,
Modkit

With some help from the Modkit developers, I finally discovered that the reason Modkit Link wouldn’t start up on my Mac was that the permissions on my ~/Library/LaunchAgents directory were wrong. Specifically, the “immutable” flag had been set on that directory, which made it impossible even for an admin to add files to it without first removing that flag. After removing that flag, Modkit Link started up normally and seemed to work correctly.

To see that the immutable flag is set, you need to open a Terminal and run the command, “ls -d -lO ~/Library/LaunchAgents”. If the directory is immutable, you’ll see the string “uchg” in the command output, like this:

[pollard]$ ls -d -lO /Users/pollard/Library/LaunchAgents/
drwx------ 11 pollard staff uchg 374 Nov 17 2013 /Users/pollard/Library/LaunchAgents/

You can remove the flag using the command “chflags -R nouchg ~/Library/LaunchAgents”, like this

[pollard]$ chflags -R nouchg /Users/pollard/Library/LaunchAgents/
[pollard]$ ls -d -lO /Users/pollard/Library/LaunchAgents/
drwx------ 11 pollard staff - 374 Nov 17 2013 /Users/pollard/Library/LaunchAgents/

Tom