Modkit Won't Program Device.

Hello,
I hope someone can help us here. We have one week to go until the main Vex IQ tournament begins and we are experiencing trouble with ‘Programming The Device’ onto the robot. After working in the Drivetrain and Motor, we tried to program the device and a pop up like this appears:

We are not sure why this is appearing. We need help fast.
Thanks in Advance,

CETNS Team

8aaa3a5ccb2693540fa4c0b78704b24c.png

Not sure… but check to make sure all your events are named.

For example, in the above screen, you have a “hold” event. (when “hold”) Make sure all the “When” and “Broadcast” have event names.

I also discovered last night that the names can’t start with a number, like “2hold”

Steve

We will try out tomorrow. Thanks for helping us.

FWIW I think it’s a coding error. We had a similar issue when a kid accidentally deleted a variable named col2 and “fixed” that by adding in a variable named column2.

Lou

So it seems you cannot make a variable starting with a number. I think that is the answer to our problem.

Still not working. Even when we removed the new variable and the broadcast it still is not working.

Do you get the same error when you try to download?

Can you “download to desktop” and post the program, here?

Aloha Team Zeus,
​I was looking at the photo of your code. I noticed that you created an event called “Hold” and coded it to the motor. That is fine. The error message is blocking the rest of the code but I will try to make out the code to the best of my ability. Based on what I see, the second line of code looks like it could be “broadcast” or a “wait”. If it is a “wait” then that code looks fine. If it is a “broadcast” then this line of code is referencing another program. That being the case my question is “Do you have another program written somewhere that is referenced by your broadcast?”

When coding in Modkit I teach the kids that the components are the “sub code” to the main program. The “Brain” part of the coding is where they can call upon the sub-codes and arrange them in a usable form.

You could try to take out the second line of code and download.

If you could post screenshots of your code I could be of more help. Best of luck.

Well, after trying our best to get it back up it still won’t work. I’ve tried to upload it to this forum but it doesn’t seem to attach successfully. Furthermore, Here is some screenshots showing all of our codes.
SCREENS:
Brain- http://prntscr.com/5yv007
Drivetrain- http://prntscr.com/5yv0b9
Motor 1- http://prntscr.com/5yv0ov
Motor 2- http://prntscr.com/5yv1dr [Currently Empty]
Robot- http://prntscr.com/5yv1xk

Well, on the motor 1 screen, there is some unattached code. That SHOULD be the problem.

Aloha Team Zeus,
I went ahead and typed in your code into ModKit exactly the way that you have it in your screen shots including the unattached code, File Name and even the Print line. I then pushed the “Project” button where the file name is typed in and hit Save. The code saved perfectly.

I then plugged in a brain and selected port 4 and pressed the down arrow (download) and the code downloaded just fine.

So based on the code that you sent it seems that it works just fine. However, there was not a screenshot provided for motor 2. If this motor 2 has some code associated with it then that could be a problem. If the motor 2 has no code then you may want to try the following solutions:

  1. Uninstall ModKit and Re-Install
  2. Try a new computer as some USB ports may go bad
  3. Try a new cable.

Best of luck.

We Don’t need that code anymore, I forgot to dump it.

Thanks it works!

Awesome!! Go getem at your upcoming event. Go Team!!

  • Bailey

Thank You!