Most everything that can go wrong with RobotC + Robot

Hello, due to some unfortunate turn of events I have lost all control of my robot. This started after I had a motor on my robot not working and I decided to update all the firmware. It has gotten to the point where it no longer will function with joystick and I get a debug exception when downloading. I would really like some help as competition is this weekend and I do not know if I will be able to get to school computers again due to weather issues. Any help is appreciated. RobotC is 4.52, I have updated master cpu and joystick to 4.52 aswell. I have also tried another cortex.

Did you update the vexnet keys?

no, I have been using a to a cable for testing however, so I don’t think that will make a difference.

Try using the wifi keys.
Don’t you have to update the cable too?

First, go to http://www.vexrobotics.com/vexedr/software/firmware/ and get the firmware upgrade utility. Update the Cortex (even if you’ve already done so before).
Then, go into firmware download in RobotC and only download the RobotC firmware. I had problems similar to yours when I tried updating the Master CPU firmware. These steps fixed my problem.

  • Kudos to RobotC support for their help :wink:

Alright. I did that. now I get the slow blinking yellow on cortex vex net light only, it is yellow on joystick

Wait, nvm, I got the test motor I have to work. I will check back once I connect all to robot! Thanks