Motor Controller 29 necessary?

The Motor Controller 29 is required any time you want to run a 2-wire motor from a 3-wire motor port. The Cortex has two 2-wire motor ports, and eight 3-wire motor ports.

So, if you (for example) want to run four 2-wire motors on the Cortex, you will need a pair of Motor Controller 29s.


  • Dean

Sorry to hijack the topic, but do ports 1 and 10 work as if a motor controller were used?

Yes, you they work the same. You do not need to use the motor controllers

Port 1 is reversed on the Cortex I believe. When we give it a positive value, it ends up being negative.
Other than that, ports 1 and 10 act is if they were a motor controller plugged into a regular port.

Hmm, perhaps check to see if it’s plugged in currently? Simply have the black wire from the 2 and 3wires line up. Our team has never had any trouble with ports 1 or 10 being reversed from the other 9.

The tab is on a different side on one of the ports, so it’s impossible to plug them in with the black wires facing the same direction without cutting the tab off.

I’m pretty certain that the 2-wire cables fit in either way on the Cortex, regardless of the tabs, we have some people who plug them in backwards all the time :rolleyes: Since the 2-wires only have a voltage they can be plugged in either way so the tabs are almost pointless (whereas they had an important use in PWM).

On a possibly related note: we’ve had a couple of 269 motors that spin the opposite direction to all the others when getting the same power, the same cables, the same port, everything. So just an idea, that may have happened to you too if a motor’s spinning the opposite way that it should :stuck_out_tongue:

This was a known bug in one batch of 269s last summer. Older and newer motors have not had this problem.

I just tried it and it does fit in either way. I don’t know what I was doing earlier when it didn’t…

Our brand new 269s always lock up when we change their direction quickly. I’m not sure if there’s some way to fix this or if the motor brushes are just stiff (or something entirely different). Anyone experience this before? (I would make another thread but this saves a post.)

I’ve seen this when I stick an axle with a 60- or 84-tooth gear on it into the motor and turn it back and forth by hand, but haven’t seen it when the motor is powered up and activated by the controller. Have you had issues under power?

I can reproduce this problem with a 12-tooth gear (being obviously harder to reproduce than with a more torque, but nonetheless possible).
The largest problem we have had is a motor locking up (usually it’s just one of the motors) when the arm is at it’s lowest or highest position. We can sometimes fix it by wiggling the motor, but usually we have to remove the motor from the arm because when the arm hits its stop and the motor locks, the arm is being pushed up by the stop (it essentially locks the arm in the down position).
Occassionally the problem can be fixed by “flicking” the joystick back and forth.

We opened up a motor (both the front and the back) and observed that when it locked, all of the gears could still turn with, and it was hard to tell whether it was in the motor or not because the motor (the gear coming directly from the motor visible when the green back of the motor is removed) turns extremely easily whether or not it’s locked.
I’m going to do further testing to see where the lock is, but it’s something I’ve never seen or heard of before. It may just be our hard stop making weird forces on the motor, but that wouldn’t explain it seizing while turned by hand with no weird forces.


These motors have huge gear ratios such that depending upon the manufacturing tolerances in the actual motor brushes inside the motor the motor may, or may not, be able to be back driven. Think of it this way, if we had a 1,000,000:1 gear ratio even with no motor connected at the input, the gear train would seem locked up.

I recommend moving the motor under power when you think it is locked up.


The problem is that, even when under power, they lock up. We will put in a soft stop to prevent this from happening in the future, but these brand-new 269s are very different from the ones we bought last year, which did not have this problem.

yes i had experiences with this “lock-up” issue as well
it was used on an intake and when we were still prototyping, it will lock up
we immediately swapped it out with an original 3-wire motor
if this happened during a competition, it would lock up and stall the motor(s)
which would be very bad if it was connected to another motor and that motor was still running (dual stall, or stripped things :()

Yup, this issue sounds familiar for my team as well. Typically happens to the 269s on the lifting mechanisms for us. Haven’t really noticed if electronically powering them decreases likely hood of the issue, but so far they seem about equal. Also haven’t seen this in the 393s.

Anyways, when the arm is raised fully due to being electronically/human powered, ocassionally 1 motor will lock up. We typically try to fix it with a joystick flick as previously mentioned, usually accompanied with assistance from human hands. When that doesn’t work, we’ve tried a few times to put a lot of weight and push down on the robot’s arm with our hands.

This has worked everytime so far, at the expense of a loud clicking noise inside the motors. However, generally the motor is fine after that for a while… although we have broken a few internal motor gears inside the 269s.

I don’t know if this is due to Motor Controller 29, but we had a problem with one of our drive motors making a faint beeping noise. The noise was annoying, and when I lifted up the body, the wheel would move slowly while making noise. It was weird, so I changed the Controller 29 and it was good.

If it’s a high-pitched whiney sound, then that’s because the motors are receiving some voltage, but not quite enough to make the motor actually turn. Usually very gently tapping the joystick will stop the sound (change the joystick value to something that does not correspond to output voltage).
Try calibrating your Joystick.

But I’m not putting any input into it?

Was a controller hooked up? Often the “resting” position of one of the joysticks on the Joystick controller will correspond to an input (ours is at -10) even though the joystick has not been moved. If you think it’s the motor controller (which it shouldn’t be, because it can’t provide any power), you could try testing the voltage on the output from the Cortex. If there is a voltage, then you know it’s the Cortex supplying power. If there is no voltage being supplied by the Cortex, then your motor controller is alive.