Motor Not Connected to Brain

We are trying to test out our new teleop program, but our motors are not connecting to our first-generation brain. We have tried switching the brain, cables and motors, but nothing has worked, and we have checked the code to make sure the ports are correct. When we try switching the motors to different ports, some of the motors connect, but there is always at least one motor (usually the same one) showing as not connected no matter the configuration.

Thanks in advance. Any suggestions would be appreciated.

What coding environment are you using? VexCode? If so, can you post a screenshot of your port setup? These would be helpful steps to figuring out what’s going on.

We are using VexCode.

Here is our port setup in the program:

I have been having the same issues and think it has been happening often with Gen 1 brains, what I do is remove the battery and put it back. The only thing I am worried about is it disconnecting during the match.

Can you provide a screenshot of the controller setup? What buttons / controls are assigned to what motors?
Click on the controller tab in the device list.

We were able to fix it; turns out that both motors were tried swapping are dead, so the 3rd one worked. Thanks everybody for the help!