Motor port issue

My students were having an issue with motors doing what they wanted them to, so I tried downloading the latest drivers in hopes of using RobotC to program which port does what. Then nothing worked, so I downloaded the default drivers.

Right now, we have a tank tread base with a claw attached to an “elevator” (conveyor). The motor that makes the elevator go up or down has 2 pins. If we put it in port 1 or port 10, it only moves when we move the tank forward or backward. Any ideas of what we should try?

Post the ROBOTC code you have written.

I haven’t written a code. We are using the default.
We have the motors to drive the tank in slots 2 and 4. We tried the claw in slot 8 and the “elevator” in either slot 1 or 10. When we put it in one of them, it only moves when we move the left side of the tank. When we put it in the other one, it only moves when we move the right side of the tank. The claw doesn’t work at all.

I think we have it figured out. There was a bad wire on one of the extensions for the claw. They found another motor controller and hooked that up to the motor for the elevator (so it would have 3 wires) and it worked. Still not sure why the 2 wire didn’t work in either of the 2 wire ports correctly, but at least they figured it out.