Motor Ports 1 and 10 Not Working Cortex 2.0

Motor ports 1 and 10 will not work for 393 motors. I have tried a new Cortex and that did not work. I plugged the same motors into ports 4 and 5 with motor controllers and they worked. My code is attached. Any help would be much appreciated.

Thanks
Bubble’s Control V2.c (4.8 KB)

It doesn’t look like your code uses ports 1 or 10

This may not be the issue but are you putting the cable in the right way? You may not realise but the cable goes the opposite way than the usual 3 wire cables in the Cortex

Actually it can go in either way. It just reverses the motor.

It is working now. I don’t know what the problem was. Thanks for your time.

I have the same problem but when I plug in a motor to 1 and 10, only one motor will work forward and back. The other only goes forward. I have down loaded the master firmware and default code. Is there some thing I am missing?

You probably have a damaged H-Bridge in the cortex (the transistors that control the flow of current to the motor). A common symptom is the the motor will work in one direction but not the other. The cortex would need to be repaired by VEX.