Motor RPM slows down after firmware update

I have built a robot to compete in the upcoming Vex iq squared away competition. I have updated my firmware from v2.0.1 (with modkit) to v2.1.3 (with VEXcode IQ block) on my robot brain. After preforming the update I have noticed that the robot’s motor operated at an extremely slow speed. Before the update the motors max out at 125 RPM and after the update the max out at 50 RPM. I am stuck as I can’t roll back the firmware. Does anyone know how to solve this problem? Any help is greatly appreciated.

did the motors slow down after the firmware update or after switching from Modkit to Vexcode Blocks ? There is known bug in VEXcode where motors will run slowly if you are using a drivetrain with gearing set to higher ratios, are you using a drivetrain ?

1 Like

Have you tried using these commands?


1 Like

This solved my problem, thank you.

1 Like

Oh good!! :+1: (20 char)

How do I set drive velocity with graphical C or Robot C? Am not using easy c. Thanks

In Graphical the command is SetMotor. You assign the speed value from 0 to 100… SetMotor(leftMotor, 100). In regular Robot C it’s SetMotorSpeed(leftMotor, 100);

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.