Motor shows up as Bumper, firmware 2.1.5

I have two motors that think they are bumper switches. I’ve tried updating with VexOs (via Windows 10), force update, putting only the motor in the first port, detect device port 1. Nothing changes - these two motors consistently identify as bumper switches.

I have tried 3 different robot brains with the same issue re: these two motors.

It seems that somehow they got bumper switch firmware downloaded - how can that be repaired?

Thanks,
Jenica Wilcox

5 Likes

If there is no junk and if the force download does not work the motors are toast and will need to be replaced.

2 Likes

that makes a lot of sense. I don’t see any damage, but that at least explains why it thinks they’re bumper switches!

1 Like

Thats a major issue, It has been happening to alot of people.

Umm, facts please. I’m not seeing it in any of the 50+ VEXIQ brains I work with. I have recovered a number of motors using the port 1 method.

2 Likes

I’ve had this happen, but only with two motors ever in four years of VEX IQ. It is a problem with the motor, and I remember reading somewhere how to fix it as well as watching a helpful video about it. I have always been able to recover the motors though.

2 Likes

I have just had this happen on one of my bots (I have about 28 and this is currently the only one). I have tried plugging into a new brain (port 1), changed my cable, updated brain. I would say that the brain is toast, but I tried two other motors (one fresh out of the box). Still no dice, I am concerned that this is a 2.1.5 problem. Is anyone else seeing this?

Hey @tdobinsky welcome back!

So to be clear

  1. You have a brain with the latest VEXOS on it.
  2. You plug a motor into the brain and it shows up as a button.
  3. Does any other motor show up as a motor on that brain?
  4. Does the motor that thinks it’s a button show up as a motor on any other brain?

https://kb.vex.com/hc/en-us/articles/360035589852-Smart-Motors-Troubleshooting-Electronics-VEX-IQ

This article should explain a little more.

Foster,

Thanks for the quick reply. Here are the stats and things I’ve tried.

VexOS 2.1.5
I tried a new brain (always using port 1)
I tried a brand new motor with both brains.
I tried 3 new cables with both brains.
I do have three other motors on the brain that are showing up as motors.
I have also switched ports on the original brain.

With all of these changes in VexOS it shows the motor as a bump sensor.

I believe that I tried everything in the article calvc01 posted.

1 Like

One last ditch thing, look at the pins/wires on the brain, inside port 1 and the “button motors” and see if the pins/wires look, bent/broken, I had one case of a roboteer smashing the wires with a pencil so they wouldn’t contact the cable ends.

Then I think at this point you should call VEXIQ support and work out a fix with them. Good luck