Motor stoping problem

Hi,

I’ve got problem with one of my VEX IQ Motors, it doesn’t want to stop. For example when I’m driving forward and realeasing the joystick motor slows down, but still rotating. I don’t think its a joystick problem, tried it on differen ports. Do You have any idea what might be the problem

Firstly I would try calibrating your controller. The Knowledge Base article that explains this is here:
https://kb.vex.com/hc/en-us/articles/360035954971-Calibrating-the-VEX-IQ-Controller

If you have one of the older style IQ controllers (usually just have a VEX logo on the front, not a VEX IQ logo), make sure the joystick is push down (as in actually push down into the controller) properly. Sometimes the old ones can pop up a bit and cause some friction which stops it from returning to the centre properly.

5 Likes

Unfortunately, That didn’t help. It doesn’t matter if I use a joystick or a code to control robot. if I use motor, it doesn’t stop rotating, it just slows down.

Can you create a new VEXcode IQ project. Only add 1 device, just the motor that you are referring to. Don’t add a controller or any other devices.
Create a simple program like this and see if the motor stops:

image

3 Likes

It worked. But when I connected the joystick, the problem occured again.

So likely a controller issue rather than a motor one. Are you sure calibration is correct?

image

If you try this, are the values returning to zero when you do not move the sticks?

3 Likes

Try add deadband for the controller code. Basically, when controller reading is less than certain value, e.g. 10, don’t move the motor.

6 Likes

And to learn more about how to implement a deadband, you can check the example programs in VEXcode IQ. Go to File, Open Examples, choose Motion and then use the Arcade Control or Tank Control examples.

4 Likes

Thank You. It worked.

1 Like