Motor will only go backwards, no matter what we do

We are using the following code for just a tank drive setup using omni wheels. However, this code is not working, or something is wrong with the motors, we are not quite sure. When we run it in the debugger, all of the right motors will go forwards and backwards. But the left motors, will only go backwards, and they are in separate ports, so it isn’t a y-splitter issue. They will not go forwards no matter what positive value you use. Has anyone else had this issue? Or suggestions on how to fix it?

motor[frontRightDrive] = vexRT[Ch2];									
	motor[backRightDrive]  = vexRT[Ch2];
	motor[frontLeftDrive] = vexRT[Ch3];
	motor[backLeftDrive] = vexRT[Ch3];

Also, when we run code that doesn’t depend on a channel, and have the left side go backwards, it goes backwards, but when we have it go forward, it doesn’t move at all. So it isn’t a controller issue either

1st, check in your motor/ sensor setup. One side should be reversed. 2nd, check your motorcontrollers and make sure the pins are plugged in the correct holes. If this does not help, private message m. Hope this helps!

Edit: check to see if the code is not in the while loop or have them set as a speed outside of the while loop.

We did check in the motor and sensor setup, everything is correct there. The pins are plugged into the right holes, again, the motors will go backwards, but will not go forwards, even if we try a simple program such as:

while(true)
{
motor[leftFront] = 100;
motor[leftBack] = 100;
}

They don’t move at all, however, if we change the value to -100, they will go backwards.

It might be the motor controllers because they have sometimes stopped working for one direction while still working the other. (It’s not very likely that that happened in two MC29s… but it’s still worth looking at.)
The easiest way to test this is to reverse the polarity on the 2 pin part (i.e. opposite colors instead of red-red black-black). If the motors only move forwards now, then the motor controllers are the issue.

If the MC29s aren’t the issue, try changing ports in the motor configuration and see if it works.

It wouldn’t be the motor controllers, we tried even putting the motor in port 1 or 10 and it did the same thing

Same thing happened to me. What ports are you using? Were you using port 1 and port 10? If yes then the motor controller inside those ports are fried.

We originally had them in 2 and 9, then the issue arose and we changed it to 1 & 10, the same issue. But, when we put the right drive motors in 1 and 10, it works fine, forwards and backwards, so the motor controller inside isn’t fried. Would there be any reason that a motor would only read a value in one direction that isn’t because of code?

It may just be a broken motor, try a different one and if that works then problem solved. I test motors using a 9v backup battery.