motors do not work

two of our motors stopped working while creating the clawbot and I have replaced them with new motors and they still do not work. have tried different cables and now motors.have calibrated as well. any help?

Here are a couple basic things to check:

  1. Make sure that the brain is being restarted whenever anything is plugged in. You have probably already done this, but it’s worth mentioning. If you are switching cables around it is easy to forget this step.

  2. Try running the firmware update utility with the motor plugged in. If the motor does not appear in the list of connected devices then it could be a bad cable or bad motor. Isolate the problem by only plugging one motor into the brain. Try substituting another motor and/or another cable (remembering to restart the brain each time).

Also, if any device (motor or sensor) is not detected, in addition to a faulty cable there could be a device update problem. Connect the device to port 1 on the brain and run the updater again. This solved issues for me with two motors and a sensor.

What is the best way to test for a bad cable ?


The easiest way to test for a bad cable is to swap the cable for a known good one to see if the problem persists, or to see if the problem follows a suspect cable.


  • Art