Motors fighting each other!

The current iteration of the Squared Away robot has a manipulator attached to a rack and pinion lift. Both components have two motors, placed on opposite ends of the same axle. Both components have one motor reversed in the programming.
For the manipulator, the axle connecting the motors turns a fork that picks up cubes.
For the lift, the axle connecting the motors goes through pinion gears on a vertical rack.

The manipulator works great. It can rotate both directions, and stop when the button is released.
The lift doesn’t work at all. It stutters and seizes, as if the motors are fighting each other. If we unplug one motor, it works fine. If we unplug the other motor, it works fine. We’ve tried different motors and different ports, and always get the same result.
Torques are set to 100%, speeds are set to 50%. The corresponding part of the code is pasted below. The top half is for the manipulator, the bottom half is for the lift.
The lift works fine in the autonomous programming. This issue only arises when we try to use the controller.
What are we doing wrong?
image

Go to device setup and look at the controller. Are any of the motors also assigned there?

@sankeydd didn’t you say that you needed an “until button not pressed” block?

You can do it that way, but instead they are using the event for releasing the button.

This was the solution. Somehow, motors were mapped to Button E. We would never have thought of that. Thanks for the help!

2 Likes

I troubleshot these things with the kids all the time. They click everything…

2 Likes