Motors in ports 1 and 10 don't work properly

We have a robot with ten motors, so two of them have to be plugged into ports 1 and 10. We are using 393 motors and these two are plugged directly into the Vex Cortex, without motor controllers. With our main program neither of these motors work. One makes a noise but doesn’t turn. So we wrote a short program to just move these motors with the push of a button on the joystick. With nothing hooked up to them, just a loose motor, they will turn forward, but not backward. When attempting to run them backward, they just hum. Is there something different about programming motors plugged into ports 1 and 10?

We have some Y splitter cables we could use, but I don’t think there’s any way to reverse one of the motors. Any place we’d want to run two motors simultaneously, one of them needs to run in reverse. Can we simply reverse the 3 prong wire in when plugging them in?

Thanks in advance for any help you can give us.

Have you switched motors around with different ports to make sure the motors are working fine? If you do that and are able to isolate the problem to the two ports, try a super simple program that eliminates most other sources of error, something like:
Power 127
Wait 1 second
Power -127
Wait 1 Second
Power 0

If it still does not work there is a possibility it is a damaged H-bridge inside the Cortex.

Reversing the direction of a motor is really easy, just plug in the 2-wire connecter backwards. Don’t change the orientation of the 3-wire connector though.

Try taking it apart and swapping the gears for new gears and look for any problems before doing anything else. Our team last year had this problem but we were able to switch out the gears and have some of them work and when some of them didn’t work we just put new motors on.

To isolate error you could hook up your two motors to the ports on the cortex, then plug them into a computer using an A to A cable and manually change the motor speeds in the debugger.

If your still experiencing errors try another motor, there is a chance you motor has a problem with your cortex’s motor port :stuck_out_tongue:

If that still fails (and fails consistently), you may have a damaged H bridge :frowning: If you have access to another cortex you should test with that cortex, if it works without any errors, then its you can attribute the issue down to that specific cortex.

One thing you can do is make sure your cortex is updated to the latest firmware and that the pins ( or ports ) are not damaged.

if its just one and 10 you could just use a power expander and put them in there.

I dont quite understand how this would help :confused: Im not even sure if you can hook a 2wire into a power expander port. If the H-Bridge is dead ( one of the scenarios ) then it will have no effect on the motors and if the programmings wrong or the motors are damaged, adding a power expander will do nothing :confused:

I think one of our teams has a similar problem, where ports 1 and 10 act weirdly, so that cortex may have a damaged H-bridge as well. Is there any way to fix it, or do we just have to avoid using those ports? Also, in the interest of preventing damage to any more cortexes, what things could damage the H-bridge in the first place?

You could fix it, but you’d first have to find out exactly which part is damaged and find an identical replacement. And there’s also the risk of making worse damage, as well as that the Cortex would not be officially legal for a competition robot. This thread has some info that might be interesting:

I would contact VEX and see what they suggest. Even if it’s not under warranty any more they might be able to fix it for a fee. Repair Policy:

In terms of what could cause the problem, the most common cause seems to be a shorted wire somewhere, possibly followed by the mystical Cortex smoke.](

I think I tried everything listed before posting this. I tried a different cortex, I switched out motors, I tried the motors hooked up to other motor ports besides 1 and 10, I wrote a simple program to run the separately from my main program. Everything pointed to ports 1 and 10 working differently.

Right after I posted, I tried using Y splitters to avoid using ports 1 and 10. When I wrote this, I was thinking that I wouldn’t need motor controllers when using the Y cable for some reason. When I realized that I needed them, I reversed one of the two wire connectors to make my motor spin in reverse. Everything works fine now that I’m not using ports 1 and 10. It still seems like they work differently.

Interesting, but that relates to ports 2 through 9.

This is more relevant, H-Bridge in the MC29 uses the same parts as ports 1 and 10 on the cortex, however, I suggest you call vex support regarding repair.

Thanks, we may look into that when we get a chance.

Oops, I copied the wrong link while reading through a bunch of different threads. Thanks for the correction!