Motors not responding to Vex Joystick: RobotC?

Hi Vex Forums,

My motors are continuously moving at speed 1 (according to the RobotC debugger), and they don’t respond to the joystick when I move the joystick channel to a different position. The motors just keep moving without control…

Here is my program in RobotC:

task main()
	while(1 == 1)
	motor[port2] = vexRT[Ch2]; 
	motor[port3] = vexRT[Ch3]; 


I put the motors in port2 and port3, which is all correct. I do not know why this problem occurs: I compile & download correctly, but this problem persists. This code was provided from an online educational resource, but it doesn’t work.


What does the motor sensor setup screen look like? Do you have the pragma statements up above to define motors in ports 2 and 3?

Assuming you are doing BEST, did you connect the terminal two-wire of the motor to the motor controller

I think this problem is due to my joystick not being calibirated because I tried adding pragmas and everything but nothing worked.

Today when I tried to calibrate the joystick the lights weren’t flickering when I put a paperclip in the hole of the vex controller and held onto the 6 button down. Does anyone know why?

Yep, it turns out I had to calibrate my joysticks.

Follow these instructions to fix the problem: