Motors not reversing with VEXcode IQ Blocks

Hi all,
I’m out of ideas on how to fix my programming issue!

I have 2 motors that are not running in reverse whichever way I program them.

I’m attaching a screenshot; the motors giving me trouble are “LeftChute” and “RightChute”. They run together on 1 button - L up, or L down. The motors running at the same time is not the issue, it’s that whichever button I push, they rotate the same way (opposite of each other (which is correct), but instead of going clockwise:counter clockwise (as forward) and counter clockwise:clockwise (as reverse) they just stay clockwise:counter clockwise when programmed as either forward or reverse . I realize that in the screenshot, both L up and L down say RightChute reverse, but that’s not the issue because I’ve tried all configurations of forward, reverse (for both RightChute and LeftChute), tried assigning the controller to certain buttons with no change, tried running the motor or motors on reverse setting in the devices pannel, and tried using a button other than L down.

Any suggestions??


try switching the order of the “spin” and “set velocity” commands (ie. use set velocity first, or not at all, there’s no need to keep setting it to 36%, that only needs to be done once unless you change it to something else in another section of code), I have a feeling you may have found a bug. If a motor is already spinning, the set velocity command will cause the motor to change speeds, but I have a feeling that using percent as the parameter will always make it move forwards.

1 Like

A couple of things…

  • In general, if you are comfortable using the blocks to code movement, don’t also use the commands under the controller. They don’t always play well together.
  • Set the velocities first, then spin the motors.
  • You only need one “when L down is pressed” event block to run both motors.
  • You can set all of the stopping modes and velocities under the “when started” block
1 Like

In my many variations of trying to get this to work, I have tried all of those things, except putting all of the stopping and velocities under the “when started” block; so I will try that.

Another thing is that the ArmLift works both forward and reverse with velocity set 2nd, so it doesn’t make sense to me why it wouldn’t allow the same for the chute movement?

AH! Moving the velocities to the “when started” block worked!!!

Thanks for saving my sanity!!! :smiley:

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.