My computer breaks Vex Vision sensors?

Ok, kind of clickbait title, but mostly not. Here’s the full story:
I wanted to start coding my team’s robot at home, so i brought home a Vex Brain, Battery, and a Vision sensor. My first issue appeared when I tried to plug in the brain. The computer simply wouldnt recognize that a brain was plugged in. I saw a forum post about this and switched the cable and reinstalled the brain’s driver with the “Console driver installer” or whatever its called. That worked, and the brain connected to my windows 7 desktop computer. Success! Now, time for the vision sensor. I plugged it in, and it didnt recognize. Learning from my past travails i ran the console downloader yet again. I checked devices manager afterwards, and saw that the USB device has been recognized as a Vex vision sensor, but it had an issue. After running through the “troubleshoot” task multiple times, with no change, I decided to try something new. i went into the properties, into the driver setting and I, well, I manually selected the vision sensor driver from the Vex Roboitics drivers folder that was automatically installed on my computer with my installation of Vex Code v5 Pros. Im not sure if this was a mistake or not, but it sure doesnt work. When i try to use the vision sensor, it says disconnected on the V5 pros vision setup tool.

But here is where the interesting part starts:

I figured that the vision sensor was broken, so I took it back to school to get a new one. I tried it on one of the school computers, and it didnt work. Great, so its broken. I grab a new one, test it on the school computer, it works perfectly, and i take it home. I plug it in to my computer back at home aaaaand, it doesnt work anymore.

I really dont know what is going on. Ive had a couple of theories:

  1. maybe vision sensor isnt compatible with windows 7?
  2. i messed something up with the drivers, which i also dont know how to fix
  3. Something on my computer is corrupting the firmware on the vex vision sensor.

if you couldnt tell, im not necessarily a “tech person.” I know more than your average joe, but by no means does that qualify me to fix this. If anyone has any help, or has experienced a similar problem, please let me know. Thanks for reading!

TL:DR vision sensor dont work on my computer :frowning: driver is messed up. Dont know what to do.

This one. It’s this one.

It will work with Windows 7, although we don’t really support Win 7 anymore as it was end of life in January 2020.

The vision sensor drivers for PROS and VEXcode should be the same, we provide them to the PROS team. The vision sensor utility can only download new firmware to the vision sensor if it is connected in DFU mode, a dialog would have asked you to select a new firmware file, I assume you did not do that.

It’s more likely to be a hardware issue with your PC’s USB port or something like that, how old is the PC ? can you test with a powered USB hub between the PC and vision sensor ? that sometimes helps.

9 Likes

My PC is about 5 years old, self built. The USB hubs I’m using work with most everything else I have tried. They successfully download code to an arruino, and can read flash drives as well. Can you elaborate on the test you recommend me to try? Also, should I upgrade my computer to windows 10 then?

I mean if Windows 7
is the problem u should upgrade it to windows 10

2 Likes