My cortex is being strange, and I can't find anything online

For context, our robotics team is brand new. We got a new teacher, and out of seven people, five are freshmen, with no prior experience with vex. The previous robotics teacher was the band director, who was told to run the club. Anything I have done this year was me teaching myself. (Programmed two robots.) I tell you all this to say, we have very little understanding of what we are doing. Anything you can suggest would be a great help to us. Even the simplest thing. ( We have VEX edr btw.)
The problem:
We have several Cortex Microcontrollers, that don’t work. We have three that work, and they are all already on robots. Most of the ones we have that don’t work all do the same thing. (Note: I have been trying to get them to work since August, it is now May.) They will have all three LED’s solid red, with the VEXnet LED occasionly flashing red. Not regularly, just random. (I have tracked it) I have tried reconfiguring the Cortex. resetting the code, using the VEXnet competition switch, and many others.

Edit: It is entirely possible that it is simply broken. (South Texas, no AC during the summer, regularly over 98 degrees outside FYI)

What do you mean by reconfiguring the cortices? I’d hate to be that guy, but did you do a firmware update?

I would suggest trying a firmware update? It seems weird that all of them wouldn’t work, also has it worked wired without the VEXNET?

I have tried pressing the “config” button on the cortex, and tried updating the Cortex and controller. (Just in case.)

It won’t work at all. I don’t know if it broke, or even if it’s fixable.

Are you sure that your firmware update is the most current version? You may need to uninstall and reinstall your programming software to get everything up to date.

Besides that, you should check to make sure that A) your batteries are charged, and B) your USB and battery ports on the Cortex aren’t loose around the things you’re plugging in. We’ve had issues with loose VexNet keys that wiggle in the port and cause random disconnects. There have also been keys that were snapped in half inside the plastic casing.

Have you tried doing a software inspection in robotc, I can’t remember exactly how to get to it but I would check to see if that has any outliers in it also check your batteries just in case

(Wow, dealing with broken keys must have been fun.)
I tried re-installing the programming software, I have tried many different batteries, that I know were charged, and I’ve checked the Vex net key port and keys.

Did it successfully update the firmware? Did you try running it manually or automatically?

It did successfully update, and I have tried running it manually and automatically.

Did you do both Master CPU Firmware and then RobotC firmware in that order and then download your program

Yes. (And the other way around just in case.)

All lights on red might suggest a dead battery. Is there a 9v backup battery plugged in? A dead one of these can cause the robot battery to behave strangely. Are the 7.2V packs definitely fully charged?

Battery could potentially be dead, make sure your batteries haven’t gone bad, our cortex batteries were only about 2 years old (mybe less) and they were already lasting about 5 mins.