My Vex IQ 2nd Gen Controller is not charging and I don't know why

I only have one VEX IQ battery(for the controller) and it says 3.7V. I have tried looking through the forums and most said that taking out the battery and replacing it would work. I only have one battery so I took it out and inserted it again but nothing is working. My controller is still not charging. The power LED is flashing red and the Charger Led is not showing anything when the controller is plugged in. The controller was working earlier but now it is not. What do I do?

1 Like

Contact VEX Robotics Support, we’ve found them to be helpful in the past.

Just realized that my earlier response was all about Gen 1, definitely check with VEX Support.

Thank you, none of them are bent and the battery is the same one you listed.

How are you charging the controller? Does the V2 still use the USB port to charge like a phone? This is how V1 is charged.

1 Like

Same way! All USB C.

1 Like

I don’t know if this works or is even possible for V2, but try charging through the tether cord (charging from the brain).

IQ generation 2 does not use a tether cord anymore.

Call vex support, hopefully they will just RMA under warranty.


@p0i A very similar failure mode happened to us at State a month ago, 10 minutes before the kids had to queue. Thankfully we had a backup controller that we tethered to sync and were able to go on.

Afterwards, it continued to flash, no longer how long it was on the charger. Ended up hooking it up over tether to the brain and opened on VexOS and it turned out the controller had to be reloaded. I’d never seen a controller lose its programming just from turning on the controller, but that fixed it.

TL;DR: try connecting the controller to VexCode and try to load firmware and see if that makes it happy.

Also, ours happened with Gen 1, but the flashing behavior sounds exactly the same.


Thank You! When I try to connect it to vexcode, this is what it says “Your browser connected to the incorrect IQ port - please select the not currently paired IQ Device and press “Connect” on the connection prompt to try again.” When I try it with the other one, it still doesn’t work. I don’t know what else to do.

@p0i Sounds like a definite call to tech support then like @jpearman recommended, unless there’s an idea he has on how to reload controller firmware.