Need help with literally the most basic thing in PROS


I am trying to learn PROS, I can’t seem to get the robot to run the autonomous function. Am I doing something wrong?

I’ll provide screen caps of anything else needed. I love having all these grand ideas for programming and I can’t even get it to pick up the function lol.

Thanks for yalls help.

1 Like

What exactly did you do, what did you expect to happen, and what actually happened? For example, did you compile and download to the robot, or did you run into a build error? When you ran on the robot, what happened?


Compiling works, downloading works. The opcontrol works great, when I run auton off the vex controller nothing happens.

1 Like

Okay, great. Now the only thing you have in your autonomous function is this:


This just turns one of your motors on, but it finishes running essentially instantly. I don’t recall off the top of my head, but I’m pretty sure that PROS turns all motors off by default when autonomous exits. Try adding a delay after, i.e.:


This should keep it running for 1 second.


I ran it on a 2-sec delay and got the same problem. Nothing moves or even tries to move. Good idea tho.

I gotta ask because I noticed it in the screenshot, but your files aren’t saved. Did you save them before compiling and downloading? (I don’t recall if the PROS Editor does this automatically).


Atom (pros editor) Does not automatically save files by default.


Project has been saved, still no movement or sign of life.

How are you running the autonomous? Are you saving, compiling, then uploading? Do you have any compile errors? Are you uploading the right project? Do you have any tasks in your code?
Can you show your current code with the delay.


Try putting a line at the beginning of opcontrol that runs the autonomous

void opcontrol() {
  // then the rest of your stuff

to see if it will run the autonomous from driver control.


Alright, thank you everyone for the help. There turned out to be some extremely deep problems with the project. While creating and setting up the project I had messed up file path, so I wound up creating a new pros project INSIDE a different one and then trying to open it up from the wrong file. That’s why there is an src folder at the bottom of the file tree in the screen cap.

Yeah. I goofed that pretty bad.

And I learned that you need to save, build, and THEN upload, not just upload.

Thank yall for the help! Should be good for at least like… 10 minutes before I have another problem.