New batteries are causing stalling, old ones don't. Why?

We have a very puzzling issue with our robot. This is our setup:

  • One battery powers 4 motors driving the four wheels directly (x-drive, no gearing, but turbo’d) and 2 more motors drive the intake (collector and conveyer).
  • Another battery (through a power expander) powers 5 motors driving the flywheel.

With two new charged batteries (one for drive/intake, one for flywheel) after about 20 seconds of driving, all power to the wheels and intake stops all at the same time. If the joystick is used to try and move, the robot just twitches very slightly. However, the flywheel still functions just fine.

Then, if the robot is left idle for a time, it can be driven just fine again.

However, if the drive/intake battery is swapped for a charged but three-year old battery, the robot functions just fine with no issues. The new battery powers the flywheel just fine.

It seems like the new battery power level is too much for something and when in use causes a shut down, but we have no idea what.

Please help!

Possibly the new battery can out put more amps and therefore your drive and intake are able to pull more therefore causing the ptc in the cortex to trip. Don’t quote me on that, that is just an idea.

Do you have a battery beak or other testing apparatus?

if the PTC trips could that still leave the power expander and flywheel working just fine or would that take out everything?

@Team80_Giraffes we don’t, but at an event the new batteries were reading around 8.7v, the old around 8.2v

It depends on which ptc you trip. Don’t quote me on this but I think there’s a ptc in the motor and in the cortex/power expander. If you trip the one in the motor, it takes out that motor for like 20 seconds. I’ve never tripped a cortex or power expander so I don’t know about that.

@TurboTech Whatever is happening takes out all 6 motors (i.e. all the ones NOT on the power expander) all at the same time, so I don’t think it’s a motor issue…

Have you tried switching up the motor ports? The internal ptc’s run in sets so that may change something.

It could be a loose connection to the Cortex from the battery leads.

Make sure the old battery tines are not bigger than the old one or the Cortex end has gotten a bit loose. Give the female end in the Cortex a little squeeze to prevent power interruptions. It only takes a small gap.

The battery extension wire seems to help in these regards on some of our older well loved Cortexes.

@Team80_Giraffes Thanks! It happened three times in a row (during competition!) using 3 seperate new batteries (the first time we’d ever used them), and then when we swapped to using a cycle of 4 old batteries it never happened again. I’d be very surprised to see than kind of consistency (both ways) if it was just bad connections. With the new batteries the x-drive shut down within about 20 seconds of usage each time during the competition. With old, no issues.

@TurboTech I think we tried that, but we’ll take another look. Thanks!