New Modkit release issues on MAC OSX (2014.10.3.0 release)

After ModKit was upgraded in the past two days, and when upgrading to the latest version of Modlink (2014.10.03.0) it seems that both FireFox and Safari and to a lesser extend Chrome all have problems on a Mac running the latest and up to date Mac OS X. We are experiencing the following issues:

**FireFox: **when dragging any robot element like a motor onto the Robot painter screen, after one such element is dragged, no second instance can be added. In some cases a shadow of the dragged object also stays behind when switching to the Block mode, rendering programming impossible

Safari: when signed-in and browsing for a project, all the stored projects are shown but NO project names so it is impossible to find your projects back

Chrome: a random amount of both the described above FireFox and Safari issues occur but very unpredictable

We are for now are returning to the May 2014 version of ModLink driver allowing us to use the previous version of the Editor where no such issues are occurring.

Our question is, has anyone else seen this behavior?

Also, the project -> browse menu has a greyed out option to browse/load on your local desktop this would be VERY useful in many school environments to be activated, any idea when this may happen?

Hi wscolten,

Thanks for your detailed report. We’re sorry you’re experiencing these issues but are happy that the ability to use the previous version helped. We were aware of the project name issue in Safari and are working on a fix. We will update you here when that and the other issues you noted are corrected. Chrome is certainly the best supported browser and the one we test most extensively in.

If anyone else has any issues with the new version, please let us know and keep in mind that you can always use the previous version here: http://modkit.com/old/vex/editor The previous version will search for Modkit Link and will not find the new version but will present a small “download” link to get the appropriate version of the Modkit Link helper application.

Also, the local desktop option will be available in the Desktop version of the software which will be a paid download whereas the web version will remain free. Once available you will be able to purchase this in the VEX store and from our website so stay tuned!

Thanks!
Modkit

Just an update. The Firefox issue has been resolved and the fix is live at http://modkit.com/vex/editor. We’re still working through the Safari issue. We’ll update you again when that’s fixed. Thanks again.

Thanks for the updates. Yes indeed the FireFox issue is solved but a new one has cropped up. It now is no longer possible to browse for stored projects. If I run it and tell it to use the 2014.05.28 ModKit Link during startup, it indeed falls back to old/vex/editor and I do have the ability to browse for the stored projects. If I choose to continue without Modlink - it seems it is then using the Newer version of the software, I can not browse for the previously stored projects.

One of the problems with Chrome for us it that the School District prohibits it’s use because of certain security issues around minors using the software. So we are ‘stuck’ with Safari and FireFox.

Thanks for your continued help.

Another update: We fixed the Safari Browse issue (missing file names) and our testing does not show any issues with browsing for old files on either Firefox or Safari. We’ll continue to monitor the forum but the best way to get help in the future is to send a support request to vex@modkit.com so that we can better track your issue and respond.

Thanks,
Modkit

3c5498225f564f03cbcfb891cd894a36.jpg

d3e25a309188fde29faae5a31d5027f6.jpg