no communication link to computer

I am having problems with my Cortex. i had sensors that were working and then out of nowhere they stopped.( all of them) so i went to download the master code to the cortex and it wouldn’t connect so i used my friends computer and it didn’t connect with his either. We have an older cortex laying around so we tried with that one and it worked fine but it has other problems so we can’t just use that. any suggestions?

Compiler and version??? Cortex version ( see bottom)

compiler: its Robot c (ran on a mac)

Cortex version: REV#: A3
RobotC version: 3.05

Downloading master code from a Mac is not fun, I have to jump through hoops to get it to work, use a PC.

There has been issues recently with RobotC 3.06…
See: Problem with RobotC 3.06

Can you describe anything else that happen, just before your Robot stopped working???

Just updated the robotC version to 3.08
The robot still works. the problem is with the sensors. All my motors work by none of my sensors(quad encoders)

I don’t think v3.08 is available, yet… RobotC v3.06, Release #2 was available yesterday afternoon… Is this the one that you Downloaded and recompiled your code with??

This Encoder Issue does not seem to be related to any of the recent Cortex Issues…

You will need to post, at least some of your code so One of us to try and reproduce the Issue…

To help us help you, please answer the following questions.

You say “all my sensors (quad encoders)” what does this mean?
How many quad encoders do you have?

Do you have any other digital sensors and if so what are they?

Do you have any analog sensors and if so what are they?

If you look at the sensors debug window, what do you see? Does anything toggle from 0 to 1 or show a number?

Do you have a VEX led available? If so, can you plug it into a digital output port and see if turn on?

Do you have a bumper switch or limit switch you can connect?

Are the black wires going to the quad encoders towards the outside of the cortex?

Are you programming through the joystick or with a USB A-A cable ?

Thats enough to start with.

  1. i have 3 quad encoders
    2 and 6) i have 4 bumper switches. nothing from them.
  2. i have a line follower that works
  3. the all the digital ports read 0
    5)i don’t have a vex LED
  4. they were correct because it was working and without changing anything they stopped responding.
    8)it lets me program with the joystick but not with the A-A and i need to download the master code.

any other questions?

v3.08 might not i started up robotC and it said in the bottom 3.08 but i just this morning updated robotC so i have whatever just came out.

So that sounds like analog ports are working but not digital. My first reaction is that the 5v to the digital ports is shorted to ground, however, I had always assumed that digital and analog ports shared the same 5v power. With all digital ports disconnected and set as digital inputs they should read as “1” in the sensors window. Have you any way of checking the 5V power on the center pin of the digital ports?

Are you still using a Mac? If so which VM are you using, Parallels or VMware? I have not had much luck loading master firmware onto the cortex from the built in USB ports on a Mac, it starts the download and then fails part way through. I have a workaround that uses an external USB server but it’s not easy, far easier to use a PC for this. What master firmware is in the cortex?

This is correct. The “new” 3.06 is denoted v3.08 in the about dialog box.


Don’t the Analog and Digital Inputs get their power from the same feed??

If there was no +5VDC, the Line Trackers would not operate…

I would use a 3 Wire cable extender and a Volt Ohm Meter ( VOM ), a Couple of small wires or even a paper clips can be CAREFULLY inserted in to the Ground and +5VDC, WITH OUT LETTING THEM SHORT TOGETHER, and the use the Meter to test for the presence of Voltage…

If you don’t have a VOM, an LED and a 1K Ohm resister, placed in Series can be used to check for Ground and +5VDC… Again, with the Bare Wires, DON’T THEM SHORT TOGETHER!!!

I have had good Luck with Virtual Box, on the PC and Mac. Also the New VCP Drivers might work better, once the Master Code is Updated…