No driver found


I’m on Windows 7 and I’m trying to update Vex Firmware for the first time. When the firmware update setup gets to the point where it says it’ll install drivers and I press OK, it completes but Windows can’t find the drivers:

If I plug in the brain, Virtual COM Port is added to the list with No driver found also. I’ve tried reinstalling the Firmware Update program, uninstalling the drivers from Device Manager, rebooting, and nothing has worked so far.

I found this thread…com-port-error through Google but the advice in it didn’t help either. Any help would be appreciated, thanks.

I’ve not come across this problem before, but here’s something to try:

After installation, look in the install directory (for me that’s C:\Program Files (x86)\VEX\VEX IQ Firmware Update) and you should see the following:

  1. The DriverInstaller.exe program
  2. The Drivers directory with installer_x64.exe and installer_x86.exe
  3. The usb_driver directory with installer_x64.exe and installer_x86.exe

First, disconnect the VEX IQ Brain from the computer. Then try running the DriverInstaller.exe program, and then see if connecting the brain shows the USB device in Device Manager.
If not, disconnect the Brain again. And then try the installer programs from within the Drivers and usb_driver sub-directories. Use the _x86 version if you’re running on 32-bit windows, or the _x64 version if on 64bit windows. Then try connecting again.

Thanks for your reply, unfortunately running the programs didn’t work. If this is a particularly strange problem to have, I can reinstall Windows since I have it set up so that my stuff is on a separate drive.

edit: Reinstalling Windows didn’t work either. I’ll try posting at Official Answers

The next step is probably to look in Windows Event Viewer to see what the failure information is for the driver install. VEX technical support should then be able to diagnose further.

I don’t know what happened or why it didn’t work at the start, but I think it’s okay now. What I did was:
In Device Manager, right clicking the device -> Update Driver Software… -> Browse my computer for driver software -> Let me pick from a list of device drivers on my computer
In there I navigated to some generic USB driver, I think “Standard Universal PCI to USB Host Controller”. After selecting it and installing, I uninstalled it, and the next time I plugged the VEX in it was recognized. Seems like the problem was over something very simple, but I have pretty much zero experience with driver stuff so I don’t know.

Thanks for your help though, the event viewer nudged me in the right direction.