No firmware is currently available for this device type

Posting this here as well:

when I try to use the Vex Firmware Updater, it first searches for updates and finds them “for 28 product(s)”. However, when I press any available Update button with a Vex connected, it says


No firmware is currently available for this device type.
Use the Update->Check for New Versions menu option
to see if new firmware is available.


Checking for new version doesn’t help. I tried reinstalling and running it as administrator on two different computers which didn’t work either. The same problem occurred with all the Vex robots I tested.

Any help would be appreciated.

The initial “28 updates” means that the updater has downloaded 28 firmware files (7 devices times 4 environments) and you should see this only once (subsequent Vex updater invocations should still perform online check, but shouldn’t see any more new versions).
So you see the brain and devices connected, “current version” different from the available versions and the “Update” buttons enabled? And pressing “update” just showing the error dialog?
That would be really strange. Can you post a screenshot?
If you run the updater again, does it repeat the message about 28 updates? That would suggest the updater having problem persisting the firmware files.
Can you check the presence and size of $USERDIR/AppData/Local/VEX IQ Firmware Update/Firmware.db
You can also check, or post the content of Log.txt in the same folder…

Hi dm89132,

We are sorry that you are having this problem.

This issue is likely the result of network security settings that are preventing the VEX IQ Firmware Update Utility from downloading the latest firmware files and saving them to your computer. To help isolate if this is the issue, please try to download the VEX IQ Firmware Update Utility to a personal computer at home.

If your Robot Brain communicates with the VEX IQ Firmware Update Utility on a personal computer at home, but not on any school computers, please contact your local school IT department to for help in resolving which computer/network security setting may not be allowing the VEX IQ Firmware Update Utility to properly function.

If you have any additional questions, please contact our tech support folks at or by calling +1-903-453-0802 so we can help resolve this issue.


  • Art

Hi, thanks a lot for the replies.
The AppData folder is indeed empty apart from the Log which I attached though I didn’t see anything interesting in it. The computers belong to a library, but are supposedly ‘unrestricted’ ones that aren’t handled by the IT support. I tried to use the Updater while using the connection from my cellphone, and also tried to momentarily disable the firewall etc. to isolate the issue, but nothing helped. For now I unfortunately can’t test the robots on a personal computer, though I figure it should work.

Log.txt (15 KB)