Not all motors responding

My team is having an issue in which when we try to use the user control on our robot, and only two motors will work at a time. We have tried switch the VexNet key, the cortex, and we have tested all the motors. We tried switching around what ports the motors were plugged into and still no luck. We have tried updating the firmware, as well as changing the battery, and just about every programmer on our team has looked at the code and we have found no issues. Whenever we try to change something to fix it, a different two motors work. I attatched a picture of our problem description in our notebook and that has a diagram if my description wasn’t clear. Does anyone have any ideas about what might be wrong?
IMG_0210.pdf (2.21 MB)

It would be nice to have:
!) A copy of your code.
2) Which ports your motors are plugged in to.

Try testing by taking one motor at a time and test it in each port. You need to find a way to isolate what the problem is. Switching more than one thing at a time makes trouble shooting very difficult.

Are you making sure to use 29 motor controllers on your motors?

Thank you for all your help, we were able to get it to work, it turned out that one of the motors was not connecting properly!