Nothing turns on

I tried to update the brain but it said a program was already in use. Kept prompting me to update. I tried a few more times. The screen began blinking and now it won’t turn on. Even the battery won’t turn on.

I don’t know what you would need to do about battery and brain not turning on (that would be question for @jpearman or VEX Tech Support, but we had similar error when we tried to upgrade V5 firmware for the first time.

The computer on which we run Vex Coding Studio already had Robot C and an older version of VEX OS update utility installed. Every time VCS would try to update V5 brain firmware it was interrupted mid-process. Only after everything was uninstalled and only latest version of VCS installed back the firmware upgrade finally worked.


What version was the brain running before you tried to update ?

@jpearman Whatever it came with. I reset the battery and reset the operating system on the brain so that’s fixed but I can’t update the firmware.

Mac or PC ?
Where/what exactly said a program was already in use ?

Try the stand alone updater available here (make sure VCS and any other programs that may try and communicate with the brain are closed)

VCS said a program was already in use. I’m on a Mac.

From the link you sent:
Do I do this:
“A standalone VEXos updater is also available for both Windows and Mac.”

Or this:
“Like the V5 System, the VEX ARM® Cortex®-based Microcontroller, VEXnet Joystick and VEXnet Key 2.0 each contain its own firmware. To update this firmware, you will need to download the VEXnet Firmware Upgrade Utility, the VEXnet Key 2.0 Firmware Upgrade Utility and the VEXnet Serial USB Driver.”

The Mac firmware utility won’t download. This is the first option I asked about. The standalone VexOS updater. The second set of options are for PC only.

yes, that one, the other utility is for the cortex.

What version of OSX are you running ? vexos 1.0.0 was not compatible with Mojave so you can’t update using that.

So you can’t even download the V5 firmware update utility from the above link ?

Can you post a screen shot of the error message

Do you ever see connection to the V5 like this ?

I got it to download and update. Thanks a ton. I do have Mojave. Of course that would be the case. #sarcasm. Thanks again.

I had a similar problem with a cortex. It wouldn’t turn off when we flipped the switch, or even when we unplugged the battery. ???

Did you have a backup battery plugged in?


I think it may have been because one of my motors was being spun by the rest of them