Odd single flywheel Issue

Hi everyone,

I’m having a very weird issue on my single flywheel. When the motors start up quickly, they start hesitating and do not pick up speed. When I use the program to slowly start up the motors, it works better, but they take around 6-7 seconds to reach full speed. This flywheel is going to be used for both full court and half court, so it needs to be able to reach its full speed quickly.

It currently has 2 motors with a 1:33.6 gear ratio but I have tried 4 motors and I have tried rebuilding the entire system. Thank you.

This sounds something like what what was happening to us a little while ago, so do your motors start but when they reach your target speed they start to jerk around and won’t stop? Are you using a velocity control code. When we took out ALL the velocity control on ours it started to work again.

No, when the motors start, they jerk around. If I slowly bring them up to speed, it works fine even at full speed. I do not have velocity control either.

Might be a damaged wire. I had a similar issue and found some of the insulation was damaged.

That does sound like a damaged wire, or it may be a code issue. Also, a 1:33.6 sounds WAY to high for two motors to handle, but if it works, don’t take my word for it that it won’t. Could you post your code so we could see if that’s the issue?

Thank you all soooooo much for helping me out. It ended up being that the ratchet gear was close to being rounded inside, so it was stressing the motors because it wouldn’t free spin or spin smoothly with the axle. But now I’m having another issue. After I launch a ball, it goes about full court at around 80, but then the motors don’t ever bring the motors back up to speed. Is that because the motors are weak. Would changing the motors help?

Velocity control would be of the most assistance to you in this case. If that doesn’t work, t may just be because that ratio is too much for two motors to handle.

I second that. If you have a configuration that uses 4 motors like you had said, try that again to see if that fixes the issue. My best guess is that you have run the gearing way too high and are close to stalling your motors.

Ok thank you. I have a PID programmed, I just need to test and tune it to see if it works. I will work on this over the next few days.

I added the other 2 motors as well, so it is running off of 4 motors now.